How can I prevent PCIe go into power save? RRS feed

  • Question

  • I am on developing some USB device, but I was facing a problem about data transferring with Surface Pro. Some data was disappeared during data transferring.

    Finally, I found the solution that just modify [Settings]-[System]-[Power Option]-[Advanced Setting]-[PCI Express]-[Link State Power Management] from [Maximum power saving] to [Off].

    However, I don't want to change any User Option, just prevent PCI Express going into any Power saving state.

    Does anyone know how to prevent PCI Express Power Saving by Windows driver with WDK or any other way?

    Wednesday, June 5, 2019 12:12 AM

All replies

  • You are indirectly changing the power behavior of the xhci controller. You are masking over the real problem. Are you using an inbox driver or custom? Have you. Captured a usb etw log trace when the data loss occurs? That will give you the real root cause

    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, June 5, 2019 3:55 AM