locked
HLK Test machine in debug status cannot be made ready RRS feed

  • Question

  • Hi,

    I cannot set my HLK Test server from "Not Ready" to "Ready".  I can "wttcmd /ping /Target: client" from server and server from client.  When I look in the HLK Manager, I see the machine listed as status "Debug" and the last update was in 3 days ago.

    I see the following error in my Event Viewer for HLK log

    <style type="text/css">p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 9.0px Helvetica} p.p2 {margin: 0.0px 0.0px 0.0px 0.0px; font: 9.0px Helvetica; min-height: 11.0px} </style>

    Failed in setting the status of 'TSTR01': Unable to set status for machine (TSTR01)

       at Microsoft.Windows.Kits.Hardware.ObjectModel.DBConnection.WttMachine.SetMachineStatus(MachineStatus status, Int64 millisecondsTimeout)

       at Microsoft.Windows.Kits.Hardware.UI.ViewModels.MachineDataContent.set_Status(MachineStatus value)

       at Microsoft.Windows.Kits.Hardware.UI.Views.MachinePoolManagementView.SetMachineStatus(MachineStatus status)

    Any idea how to debug this?  This state survives reboots of client and controller systems.  I don't want to delete and recreate the hosts - again.

     
    Monday, February 12, 2018 10:38 PM

Answers

  • Try this:
    1. Start "HLK Manager", click on "My Machines..."
    2. Select your test machine from the list, right click, "change-status" to "unsafe"
    3. Open "HLK Studio" ... "Configuration"
    4. Find your test machine, right click, "change machine status" to "ready"

    • Marked as answer by Eva Brigid Tuesday, February 13, 2018 10:58 PM
    Tuesday, February 13, 2018 9:58 PM