none
SharePoint Online tenant 'source' does not work. RRS feed

  • Question

  • I have a single tenant, if I add the 'source' attribute to a url it will never return to the address specified, only to the list. 

    Example: https://somesite.sharepoint.com/list/test/newform.aspx?source=https://somesite.sharepoint.com

    This should return to the home page of the site rather than the list view. I have compared all the site collection features as well as the site features between a working tenant and a non-working one and can't find a difference. 

    Is this a tenant setup issue? Any ideas?

    Friday, May 4, 2018 2:24 PM

Answers

  • I have to retract my last answer, I had made the changes to the proxy server but it just happened to coincide with the other fix. For some reason unless the url was fully encoded in the query string the source attribute would not work.

    Example:

    Success: https://mytenant.sharepoint.com/sites/performance-development/Lists/test/NewForm.aspx?Source=https%3A%2F%2Fmytenant%2Esharepoint%2Ecom%2Fsites%2Fperformance-development

    Failure: https://mytenant.sharepoint.com/sites/performance-development/Lists/test/NewForm.aspx?Source=https://mytenant.sharepoint.com/sites/performance-development

    Hope someone finds this helpful or if anybody knows why let me know.


    • Marked as answer by mddell Monday, May 7, 2018 2:38 PM
    • Edited by mddell Monday, May 7, 2018 2:40 PM security
    Monday, May 7, 2018 2:38 PM

All replies

  • Well this turned out to not be a SharePoint issue at all. I seems that there was a proxy server in the way causing the issues. 
    • Marked as answer by mddell Friday, May 4, 2018 6:15 PM
    • Unmarked as answer by mddell Monday, May 7, 2018 2:34 PM
    Friday, May 4, 2018 6:15 PM
  • I have to retract my last answer, I had made the changes to the proxy server but it just happened to coincide with the other fix. For some reason unless the url was fully encoded in the query string the source attribute would not work.

    Example:

    Success: https://mytenant.sharepoint.com/sites/performance-development/Lists/test/NewForm.aspx?Source=https%3A%2F%2Fmytenant%2Esharepoint%2Ecom%2Fsites%2Fperformance-development

    Failure: https://mytenant.sharepoint.com/sites/performance-development/Lists/test/NewForm.aspx?Source=https://mytenant.sharepoint.com/sites/performance-development

    Hope someone finds this helpful or if anybody knows why let me know.


    • Marked as answer by mddell Monday, May 7, 2018 2:38 PM
    • Edited by mddell Monday, May 7, 2018 2:40 PM security
    Monday, May 7, 2018 2:38 PM