locked
Debugging issue RRS feed

  • Question

  • Hi,

    When I start the ppc application in debug mode, the debugger does not break at the breakpoint. Once the debugger starts, there is no error shown and the break point is fully active. I am using Windows Mobile 6.x Pocket PC device and Visual Studio 2005.

    1) Is there any setting I require from OEM to enable debugging on device?
    2) Any other suggestion...

    Regards.

    Thursday, August 20, 2009 1:31 PM

All replies

  • Where have you put the breakpoint?  Does it come in the execution path?

    I suggest to put the breakpoint at the first statement in WinMain() function and see if it is hit. I assume its a native program.

    - Onkar 

    http://www.42gears.com
    [Solving Business Problems with Windows Mobile]
    Thursday, August 20, 2009 1:38 PM
  • Yes I had put it at the start of WinMain() and InitInstance() still it is not hit.... I use native code,

    Regards.
    Thursday, August 20, 2009 1:42 PM
  • 1. When debugging does the application launch and run normally (even though the breakpoint are not hit).
    2. Check the Debugging and Deployment settings under Configuration Properties in %ProjectName% Properties Window. They should be referring to same folder on the device.
    3. Are there multiple projects in the solution?






    http://www.42gears.com
    [Solving Business Problems with Windows Mobile]
    Thursday, August 20, 2009 2:06 PM
  • 1. When debugging does the application launch and run normally (even though the breakpoint are not hit).
    Yes
    2. Check the Debugging and Deployment settings under Configuration Properties in %ProjectName% Properties Window. They should be referring to same folder on the device.
    They refer to same folder on device
    3. Are there multiple projects in the solution?
    Yes.

    Regards.
    Thursday, August 20, 2009 2:17 PM
  • Suggestion: In the solution explorer, right-click on this particular project and select "Set as Startup Project" menu item.

    If 1 above does not work try the following:

    Close all instances on Visual Studio, Launch it again and create a new project with Wizard. Is this new app debuggable?


    http://www.42gears.com
    [Solving Business Problems with Windows Mobile]
    Thursday, August 20, 2009 4:35 PM
  • 1. Check the project setting it may be in release mode.
    2. delete app & app's folder in the device
    3. Select the debug mode in VS in press F5

    Hope this will help you.


    Siva.
    Thursday, August 20, 2009 6:34 PM
  • I have the same issue.  I'm also quite certain its some sort of OEM configurable setting, because I am able to hit breakpoints in an old version of my device's ROM, but unable to in a newer version.

    Can Microsoft please elaborate on what this "Security" setting is and how one might disable it so they can debug their applications?

    I too am using a Windows Mobile 6.1 Pocket PC device with Visual Studio 2005.
    Saturday, August 22, 2009 1:27 AM
  • Guys,

    if the issue is regarding the breakpoint then there may be possibility of becoming all the breakpoints inactive when application will get deployed on the device. So after deploying the app when it starts running then could not get breakpoint hit. If this is the issue then the resolution options I guess as follows-

    1] Make sure that you have installed following 2 updates-

        a) Visual Studio 2005 Service Pack 1 Update
     
        b) Microsoft .NET Compact Framework 2.0 SP2

    2] If you have already installed the above updates then you need to delete the application folder from the device/emulator and start with the fresh deployment.


    Thanks and Regards, Amit Rote
    Saturday, August 22, 2009 11:53 AM
  • Hi Am_ac1,

    Please install NETCF V2 SP2 on to your desktop, this will work for you.

    also see below thread discussion for the same problem solution.

    Thread


    Hope this may be help.


    If you find my post is helpful for you then mark as a answer.
    • Proposed as answer by WmDev Saturday, August 22, 2009 12:57 PM
    • Unproposed as answer by Am_ac1 Monday, August 24, 2009 10:15 AM
    Saturday, August 22, 2009 12:57 PM
  • Guys,

    if the issue is regarding the breakpoint then there may be possibility of becoming all the breakpoints inactive when application will get deployed on the device. So after deploying the app when it starts running then could not get breakpoint hit. If this is the issue then the resolution options I guess as follows-

    1] Make sure that you have installed following 2 updates-

        a) Visual Studio 2005 Service Pack 1 Update
     
        b) Microsoft .NET Compact Framework 2.0 SP2

    2] If you have already installed the above updates then you need to delete the application folder from the device/emulator and start with the fresh deployment.


    Thanks and Regards, Amit Rote

    The breakpoints are not made inactive. They are shown with full red circle but they are not hit even if the code is executed....

    Regards.
    Monday, August 24, 2009 10:15 AM
  • 1. Check the project setting it may be in release mode.
    2. delete app & app's folder in the device
    3. Select the debug mode in VS in press F5

    Hope this will help you.


    Siva.

    1. Check the project setting it may be in release mode.
    -- The build is in debug mode
    2. delete app & app's folder in the device
    -- I did this but still it does not work
    3. Select the debug mode in VS in press F5
    -- I am running my application in debug mode by pressing F5 but still breakpoints are not hit.

    Regrads.
    Monday, August 24, 2009 10:19 AM
  • Suggestion: In the solution explorer, right-click on this particular project and select "Set as Startup Project" menu item.

    If 1 above does not work try the following:

    Close all instances on Visual Studio, Launch it again and create a new project with Wizard. Is this new app debuggable?


    http://www.42gears.com
    [Solving Business Problems with Windows Mobile]

    The project I want to run is set as "Startup Project". Further the new app created from scratch is not debuggable... It starts debugger but the breakpoionts are not hit though they are shown active with full red circle.

    Regards.
    Monday, August 24, 2009 10:21 AM
  • Hi Am_ac1,

    Please install NETCF V2 SP2 on to your desktop, this will work for you.

    also see below thread discussion for the same problem solution.

    Thread


    Hope this may be help.


    If you find my post is helpful for you then mark as a answer.

    Hi,

    I already have .net version 3.5 installed on my desktop. The device I use is running Windows Mobile 6.5.

    Please suggest how to make my application debug and break at breakpoints set?

    Regards.

    Monday, August 24, 2009 10:26 AM
  • Hi,


    Can you debug on emulators? or it only failed on devices?

    Thanks,
    Zhe Zhao
    Tuesday, August 25, 2009 2:16 AM
  • For me, it only fails on this device.  I can debug on the emulators. I can debug on other devices. I can debug on the older ROM.

    Its just this device with this newer ROM that seems to cause the problem.
    • Edited by Sarev0k Tuesday, August 25, 2009 3:32 AM
    Tuesday, August 25, 2009 3:28 AM
  • Hi,


    Can you debug on emulators? or it only failed on devices?

    Thanks,
    Zhe Zhao

    Yes I can debug on emulator. But debugging on device fails. It starts debugger but the breakpoionts are not hit though they are shown active with full red circle.

    Regrads.
    Monday, August 31, 2009 8:27 AM
  • Ok, please try this may be this method help you,

    Run the app in the device
    Do the attach to process in Visual studio and check whether its stopping in your breakpoints.


    Siva.
    Tuesday, September 1, 2009 7:24 AM
  • One more think make sure your device security off (use device security manager to security off).
    Siva.
    Tuesday, September 1, 2009 9:31 AM

  • I set the device security to off and attached the debugger through Attach to process.... but still breakpoints are not hit though they are shown active with full red circle.

    Regrads.
    Tuesday, September 1, 2009 12:50 PM
  • I've tried running the executable on the device and still have the same issue, where the breakpoints will appear with full read circles, but they will not be hit.  I've also used to the security configuration manager to disable my devices security, but there is still no change in behavior.
    Friday, September 4, 2009 6:54 PM
  • Any solutions on this... ?

    Regards.
    Thursday, October 8, 2009 12:19 PM
  • please check this
    http://social.msdn.microsoft.com/Forums/en-US/windowsmobiledev/thread/7183ed58-6b6b-4cac-8d66-552113c28b45

    -Siva. * Please mark as answer and vote if my post help to fix your issue.*
    Wednesday, October 14, 2009 9:39 AM
  • This link tells about "No symbols have been loaded..." error.

    Here the problem is that synbols are properly LOADED. breakpoints appears with full read circles. Still the breakpoints are not hit.

    Any solutions to this problem...?

    Regards.

    Wednesday, October 14, 2009 11:03 AM