locked
ReportViewer on a Web page in IE RRS feed

  • Question

  • User691100447 posted

    Hi,

    I have created reports using SSRS which run and display perfectly locally in their solutions and on the ReportServer.

    However if I place a ReportViewer control in a web page I seem to have a lot of display issues, namely:

    • Text doesn't appear in the colour it should be in.
    • Underlines text is not underlined.
    • Font size and name doesn't display as expected.
    • Data Bars Graph do not show at all.
    • Images display as larger or different sizes.
    • The toggle item property in SSRS displays very messy.

    I am using Visual Studio 2008 with SQL Server 2008 R2.

    Cheers, Jon

    Wednesday, June 11, 2014 3:39 AM

All replies

  • User1519735232 posted

    Found it on the url listed in the comments. I can't believe how lame this is that when microsoft puts out a new browser they do not test as we do.

    void Application_BeginRequest(object sender, EventArgs e)
    {
        // Bug fix for MS SSRS Blank.gif 500 server error missing parameter IterationId
        // https://connect.microsoft.com/VisualStudio/feedback/details/556989/
        if (HttpContext.Current.Request.Url.PathAndQuery.StartsWith("/Reserved.ReportViewerWebControl.axd") &&
         !String.IsNullOrEmpty(HttpContext.Current.Request.QueryString["ResourceStreamID"]) &&
            HttpContext.Current.Request.QueryString["ResourceStreamID"].ToLower().Equals("blank.gif"))
        {
            Context.RewritePath(String.Concat(HttpContext.Current.Request.Url.PathAndQuery, "&IterationId=0"));
        }
    }
    Wednesday, June 18, 2014 6:54 AM