locked
Cannot sign in to Visual Studio 2017 Community Edition RRS feed

  • Question

  • I recently installed VS2017 Community Edition, and it worked fine for some time.  Now it is saying my license has expired and will not let me work.  I cannot sign in to extend my license, I get an error stating that the online service is not available.  The "Check for Updated License" link leads to a totally blank window.

    I have already tried reinstalling VS2017 and it still has this problem.  I have already tried to contact Microsoft for support, but apparently I cannot submit a ticket without buying a tech support subscription.
    Wednesday, October 18, 2017 8:23 PM

All replies

  • Hi Ryan,

    Thank you for posting in MSDN forum.

    >>I get an error stating that the online service is not available.

    Could you please tell us the detailed information about online service?

    As we know, VS 2017 Community edition is free for using, usually once we go to Menu Help> Register Product to sign in with your Microsoft account, we can directly use it without checking for updated license.

    Please refer to How do I sign up for a Microsoft account? , to create a Microsoft account for free. Then sign in VS again as below, not to click "Check for updated license":

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by 宝宝徐 Thursday, October 19, 2017 3:08 AM
    • Proposed as answer by 宝宝徐 Monday, October 23, 2017 2:30 AM
    Thursday, October 19, 2017 3:08 AM
  • Hi,

    If you are an individual developer and installed VS2017 Community, I suppose, you can use it at free charge, i.e. there is not expiration period.
    Would you insert a screenshot of version information: [Help] > [about Microsoft Visual Studio].
    If you cannot insert it in your post, please share it via cloud storage such as OneDrive, Dropbox, etc.

    Regards,

    Ashidacchi

    Thursday, October 19, 2017 3:11 AM