Setup Error installing Visual Studio 2010 SDK RRS feed

  • Question

  • Hi,

    I'm trying to install VS2010 SDK but keep getting setup error. The error reads:

    Setup has found an error before Microsoft Visual Studio 2010 SDK or one of its optional components could be installed. You need to restart the installer to try again.

    Error Type: Microsoft.VisualStudio.Sdk.Setup.MissingPrerequisiteException

    Error Message: You must have Microsoft Visual Studio 2010 installed on your computer before proceeding.


    I definitely have VS2010 installed as I've been it to build applications for the last 4 months. It's installed on my local drive "D:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe"


    Windows XP Professional Service Pack 3
    VS 2010 version 10.0.31118.1 SP1Rel
    .NET Framework version 4.0.30319 SP1Rel


    What's wrong here?


    • Moved by Larcolais Gong Thursday, March 3, 2011 3:52 AM (From:Visual Studio Setup and Installation)
    Wednesday, March 2, 2011 11:16 PM


All replies

  • Hi,

    Thank you for posting. I think your question occurred during installing Windows SDK. I'll help you moving your thread into appropriate forum.


    Larcolais Gong[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, March 3, 2011 3:51 AM
  • Thanks. Windows SDK was not mentioned in the System Requirements section. 

    I'll give it a go and see what happens.

    ps. Installing Windows SDK doesn't help. 



    Thursday, March 3, 2011 4:24 AM
  • I have the same issue and would very much appreciate any pointers as to how to resolve it. Where should I look for log output? The only thing I found in the event viewer that could be related is this: 

    Activation context generation failed for "C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\Remote Debugger\x64\msvsmon.exe". Dependent Assembly Microsoft.Windows.Common-Controls,language="*",processorArchitecture="amd64",publicKeyToken="6595b64144ccf1df",type="win32",version="" could not be found. Please use sxstrace.exe for detailed diagnosis.



    Saturday, March 5, 2011 9:09 AM
  • Ok, solved. Silly me did not to realize that before installing you must of course set the registry value: 


    to zero. (Then you can restore it afterwards)


    See this thread: http://social.msdn.microsoft.com/Forums/en-US/vsx/thread/12b2e7e5-90a0-4045-8989-9bbf3622e495

    • Marked as answer by Shawn Toh Friday, March 11, 2011 12:00 AM
    Saturday, March 5, 2011 9:24 AM
  • Thanks Karl. That solves the problem.


    Friday, March 11, 2011 12:01 AM
  • The actual problem is that you have VS2010 SP1 installed and are attempting to install the wrong version of the SDK.  The registry hack gives a valuable clue...

    I had the same problem and was about to modify my registry when I decided to read the post you linked to, in it's entirety.  Way at the bottom is the link to the SP1 version of the SDK.  DL, install, have a good day.


    Andy Bohn
    • Proposed as answer by deadlydog Friday, April 29, 2011 8:51 PM
    Tuesday, March 22, 2011 3:37 PM
  • that is incorrect - it is the VSIP SDK i.e. "Microsoft Visual Studio 2010 SDK" from here 


    thanks anyway

    MickyD | http://mickyd.wordpress.com/ Help others by voting my post as 'Helpful' if you think it is so.
    Wednesday, May 11, 2011 8:41 PM
  • hi,

    could you tell me how to set the registry value to zero,plz? I have the same problem with you....


    thanks a lot

    Tuesday, June 28, 2011 10:10 AM
  • I had the same problem. Uninstalling a previously installed SDK (also the VS2008 one if you have it!) fixed it for me.
    • Proposed as answer by Frank Witte Thursday, March 29, 2012 9:34 AM
    Thursday, March 29, 2012 9:34 AM
  • yes I agree with A_Bomb - the registry hack you might have unpredictable results - really you just need the SDK that's for SERVICE PACK 1.


    Monday, August 13, 2012 6:00 PM
  • Karl Böhlmark's answer works for install, but (in my case) at the moment of create a project extension, in the last step it hung ups without say anything.
    Wednesday, August 15, 2012 4:28 PM
  • did you try A_Bomb's solution instead? I think his solution is much better than Karl's.
    Wednesday, August 15, 2012 5:14 PM
  • A_Bomb('d) it!

    This IS the means by which this problem is correctly resolved.  I thank both Karl and A_Bomb for their assistance.  

    It'd really be sweet if Microsoft simply stated in the error message:
    "Please download the Visual Studio v10 SDK SP1, as you have upgraded Visual Studio itself to SP1.  Here's the URL for downloading Visual Studio SDK SP1"

    That'd even be logical  ;-)

    Glenn T. Kitchen VB.NET Forums

    • Edited by αβθ-Coder Thursday, December 27, 2012 3:57 PM typo
    Thursday, December 27, 2012 3:50 PM
  • Hi,

    if you have a M SDN subscription then you can download it from your subscriber downloads.

    Visual Studio 2010 Express ISO can be downloaded from http://download.microsoft.com/download/1/E/5/1E5F1C0A-0D5B-426A-A603-1798B951DDAE/VS2010Express1.iso.

    With kind regards,



    Tuesday, June 28, 2016 8:31 AM