none
Changes in the code or the designer won't update when debugging

    Question

  • I am trying to debug my VB.net app in Visual Studio Express 2015. when I realized my changes will not update on my form-on the designer or in the code. I found a solution online says "clear out the "Debug" folder under the bin" but i even can run the program after using that cos of debug target is missing.

    i have been sticking on this for hours and really don't want to redo my assignment cos of it

     Does anyone have a solution? 

    Saturday, March 18, 2017 10:35 AM

All replies

  • If you mean something like this, place a Button on the form, build/run and the button does not show or you wrote code that does not execute). If this is similar to your issue then right click on Solution Explorer and select "Configuration Manager". A dialog appears (like shown below) Make sure Build is checked for this project.

    If that does not help, close Visual Studio. Open the project folder and delete obj and bin folder then restart Visual Studio and try build/run again.

    Still not helping? Are there any third party controls on the form? This might be an issue.

    Are there any Visual Studio extensions installed? Disable them.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.
    VB Forums - moderator
    profile for Karen Payne on Stack Exchange, a network of free, community-driven Q&A sites

    • Proposed as answer by Frank L. Smith Saturday, March 18, 2017 1:22 PM
    Saturday, March 18, 2017 12:51 PM
    Moderator
  • I've had this problem on and off now for some time using VB 2017.  Tried this solution and it worked first time.  Needed to quit VS after checking the boxes, but then all went well.  

    Keeping fingers crossed that this is all it was.  Not sure how it got messed up in the first place, but glad it works now.  


    • Proposed as answer by RHWagner56 Monday, May 28, 2018 9:56 PM
    Monday, May 28, 2018 9:56 PM