none
Webdav in Office365.com RRS feed

  • Question

  • I'm trying to access to my account in office365.com but I'm always getting a 302, I think the problem is that I don't have the good url of the exchange server. This is the request:

    "<?xml version="1.0"?>
            <g:searchrequest xmlns:g="DAV:">
                <g:sql>
                    SELECT
                        "urn:schemas:contacts:sn", "urn:schemas:contacts:givenName",
                        "urn:schemas:contacts:email1", "urn:schemas:contacts:telephoneNumber"
                    FROM
                        Scope('SHALLOW TRAVERSAL OF "https://xxxxxx.outlook.com/exchange/felix/contacts"')
                    WHERE
                        "urn:schemas:contacts:givenName" LIKE '%F%'
                </g:sql>
            </g:searchrequest>

    I'm sending this request to address you can see in the image.


    Thursday, June 7, 2012 2:12 PM

All replies

  • Have you seen any documentation that says that it is possible to access your Exchange Online by using WebDAV?  I don't have an Office 365 account, but I'm sure it uses Exchange 2010, which doesn't support WebDAV.

    Mobile OWA For Smartphone
    www.leederbyshire.com
    email a@t leederbyshire d.0.t c.0.m

    Thursday, June 7, 2012 3:43 PM
  • Thanks!

    No, I was looking for it, but I didn't find anything about that, so I guess It was possible.

    I put another post about the tools for doing this: http://social.technet.microsoft.com/Forums/en-US/exchangesvrdevelopment/thread/a6038576-76fc-4b63-854d-ebe2357fb84f

    What option do you recommend? 

    Thursday, June 7, 2012 3:50 PM
  • Felix,

    You will need to use EWS. WebDav is not available with Exchange Online and Exchange 2010+.

    With regards,


    Michael | Microsoft Exchange SDK

    The Exchange Development Forum Guide has useful information for using the Exchange Development Forum.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, June 7, 2012 8:11 PM
    Moderator