none
How to install WDFCoinstaller01005 dependent drivers in Windows PE 2.0 version RRS feed

  • Question

  • Hi ,

    I am new to windows PE environment. While experimenting with drivers. I had observed that drivers which are dependent on WdfCoInstaller01005.dll are not working in WinPE 2.0.

    The same when i tried to install on Win PE 3.0 working good and observed driver services are loaded properly .

    So i had added the dependencies manually in Win PE 2.0, but still there is a issue and drivers is not getting loaded.  Is there any procedure variation for adding KMDF dependent drivers.

    Could you please suggest on it

    Thanks in Advance :) ..
    Wednesday, May 21, 2014 6:53 AM

Answers

  • Win PE 2.0 (for Vista) contains KMDF 1.5; WinPE 2.1 (for Vista SP1) contains KMDF 1.7. Therefore you do not need to do any customization to get your KMDF 1.5 driver to load there. To double verify this, I build 1.5 echo sample and use devcon install to load it in WinPE 2.1 without any issue. Your problem must be something else.

    Wednesday, May 21, 2014 7:27 PM