sticky
FSLogix Forum FAQs RRS feed

All replies

  • What GPO or registry setting do you use to generate vhdx vs vhd. I deployed using guides from FSLogix and all the user profiles are .vhd instead of .vhdx.
    Saturday, June 29, 2019 5:46 PM
  • VHDX requires Windows 8 or Server 2012 or later. If you are on a supported OS, use the "VolumeType" setting. This setting is only used when the container is created. If you continue to get VHD files, check the Profile logs.
    Sunday, June 30, 2019 2:30 AM
    Owner
  • I am on Windows 10 which brings up another question. Why were these FSLogix topics started under the Win 7 forum?

    Anyhow, I have found no GPO settings for "VolumeType". How and where do you set this besides in the ConfigurationTool.exe?

    I know that you can manually convert .vhd to .vhdx but is there any migration path from .vhd to .vhdx? What are the benefits of using .vhdx as related to FSLogix, any extra features?

    • Edited by havealoha Sunday, June 30, 2019 3:10 AM
    Sunday, June 30, 2019 2:36 AM
  • Hmm. I see "VolumeType" in the latest admx file. In any case, you can set it in the registry. The key and the value is described here: https://docs.fslogix.com/display/20170529/FSLogix+Profiles+Configuration+Settings

    You can use the Frx.exe (FSLogix command line tool) with the "migrate-vhd" switch to move from VHD to VHDX: https://docs.fslogix.com/pages/viewpage.action?pageId=6554051

    VHDX has a few benefits like larger max size, etc. But in practice VHD works pretty well as well.


    Sunday, June 30, 2019 4:03 AM
    Owner
  • I am having issues converting .vhd to .vhdx. This is FSLogix 2.9.6999.2588 on Win 10 1809 10.0.17763.557 . I verified the original .vhd was closed. Frx creates the vhdx but always quits at 3379200 kb. I have plenty of disc space and it does not matter if the original .vhd is local or on the network. Error below:

    c:\Program Files\FSLogix\Apps>frx migrate-vhd -src \\fs\vdi\S-1-5-21-blahblahblah_havealoha\Profile_havealoha.vhd -dest c:\temp\Profile_havealoha.vhdx

    Formatting volume: \\?\Volume{d6137422-28f8-4d71-bd74-c58251fa7020}\
                   Exit code: 9
    Error Mirroring files (0x0000001D): The system cannot write to the specified device.

    I also tried doing this on the file server using powershells convert-vhd command which seems to only be available with the hyper-v role. This server is already a virtualized (esx) server so I do not want to add the hyper-v role. Instead I tried to just add the rsat tool for managing hyper v. That got me the convert-vhd command in powershell but when trying to run it I get the following error:

    PS V:\Vdiprofiles\S-1-blahblahblah_havealoha> Convert-VHD .\Profile_havealoha.vhd .\Profile_havealoha.vhdx
    Convert-VHD : The Hyper-V role is not installed on the destination host. Add the Hyper-V role on that host and then run this cmdlet again.
    At line:1 char:1
    + Convert-VHD .\Profile_havealoha.vhd .\Profile_havealoha.vhdx
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Convert-VHD], VirtualizationOperationFailedException
        + FullyQualifiedErrorId : Microsoft.Vhd.PowerShell.ConvertVhdCommand


    Sunday, June 30, 2019 6:21 PM
  • What's the size of the newly created VHDX? Maybe you are running out of space there? Try specifying a size on the command line that allows for enough space.

    If that isn't the issue, get a procmon trace of the issue happening and open a support case.

    Monday, July 1, 2019 5:29 PM
    Owner
  • "Why were these FSLogix topics started under the Win 7 forum?"


    Thanks for bringing this to our attention. The FSLogix forum has been moved and is nested below Windows 10 now.

    Wednesday, July 3, 2019 6:36 PM
    Owner