locked
Problem with File Attachment Control. in web enabled infopath 2010 form? RRS feed

  • Question

  • I can upload an attachment using file attachment control in web enabled infopath 2010 form. But when iam trying to download form after submiting form. Attachment is showing but when i try to download it throws error.

    Note : These infopath forms are migrated from 2007 to 2010.

     

    Please help... Thanks in advance

    Friday, May 13, 2011 1:30 PM

Answers

  • Issue Resolved By removing the Attachment control and replace with new Attachment control and republished the form.
    • Marked as answer by Tech-Fun Wednesday, July 20, 2011 1:54 PM
    Wednesday, July 20, 2011 1:54 PM

All replies

  • Hi CV-Folk,

     

    Thanks for your post.

    First, could you share the error message ?

    Second, please check whether the link to the File Attachment is correct. You can download the Fiddler (http://www.fiddler2.com/fiddler2/ ), and then monitor the URL of the Attachment in the tools.

    Share your result.

    • Marked as answer by KeFang Chen Thursday, May 19, 2011 9:29 AM
    • Unmarked as answer by Tech-Fun Tuesday, July 19, 2011 3:49 PM
    Monday, May 16, 2011 7:05 AM
  • Hi CV-Folk,

    Were you able to resolve this? If so could you please tell me how? I'm also getting an error when I try to open an attachment from a InfoPath web form. I started to get this error after I applied February CU for SP 2010. Till then I could download an attachment but couldn't open it without downloading. I applied the CU to fix this but CU actually broke even the already existed functionality.

    Thanks in advance!

    Sajeewa 

    Thursday, June 9, 2011 4:15 PM
  • Sorry for very much delay in replying . as i was engaged in other stuff.  Back to this issue again. Here is error message i am getting.

     

    System.ArgumentException: Value does not fall within the expected range.    at Microsoft.SharePoint.Library.SPRequestInternalClass.GetMetadataForUrl(String bstrUrl, Int32 METADATAFLAGS, Guid& pgListId, Int32& plItemId, Int32& plType, Object& pvarFileOrFolder)     at Microsoft.SharePoint.Library.SPRequest.GetMetadataForUrl(String bstrUrl, Int32 METADATAFLAGS, Guid& pgListId, Int32& plItemId, Int32& plType, Object& pvarFileOrFolder)     at Microsoft.SharePoint.SPWeb.GetList(String strUrl)     at Microsoft.Office.InfoPath.Server.Controls.FormServerAttachments.FileDownload(HttpContext context)     at Microsoft.Office.InfoPath.Server.Controls.FormServerAttachments.ProcessRequestInternal(HttpContext context)     at Microsoft.Office.InfoPath.Server.Controls.ProcessRequestPageBase.ProcessRequest(HttpContext context)     at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()     at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    Tuesday, July 19, 2011 3:51 PM
  • Issue Resolved By removing the Attachment control and replace with new Attachment control and republished the form.
    • Marked as answer by Tech-Fun Wednesday, July 20, 2011 1:54 PM
    Wednesday, July 20, 2011 1:54 PM