locked
Error 500.19 local Wcf RRS feed

  • Question

  • User1885614952 posted

    I'm trying to add service reference to my windows 8 phone application and I got this message after clicking Go:

    This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".

    I can't figure it out... I enabled IIS 6.2, I'm using windows 8 and visual studio 2012

    <?xml version="1.0"?>
    <configuration>
    
      <appSettings>
        <add key="aspnet:UseTaskFriendlySynchronizationContext" value="true" />
      </appSettings>
      <system.web>
        <compilation debug="false" targetFramework="4.5" />
        <httpRuntime targetFramework="4.5"/>
      </system.web>
      <system.serviceModel>
        <behaviors>
          <serviceBehaviors>
            <behavior>
              <!-- To avoid disclosing metadata information, set the values below to false before deployment -->
              <serviceMetadata httpGetEnabled="true" httpsGetEnabled="true"/>
              <!-- To receive exception details in faults for debugging purposes, set the value below to true.  Set to false before deployment to avoid disclosing exception information -->
              <serviceDebug includeExceptionDetailInFaults="false"/>
            </behavior>
          </serviceBehaviors>
        </behaviors>
        <protocolMapping>
            <add binding="basicHttpsBinding" scheme="https" />
        </protocolMapping>    
        <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />
      </system.serviceModel>
      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true"/>
        <!--
            To browse web app root directory during debugging, set the value below to true.
            Set to false before deployment to avoid disclosing web app folder information.
          -->
        <directoryBrowse enabled="true"/>
      </system.webServer>
    
    </configuration>
    

    thanks in advance.

    Thursday, December 19, 2013 9:59 PM

Answers

  • User1885614952 posted

    Solved. I just installed .net framework for IIS.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, December 20, 2013 8:51 PM

All replies

  • User1885614952 posted

    Solved. I just installed .net framework for IIS.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, December 20, 2013 8:51 PM
  • User1027872733 posted

    richardbmotta

    installed .net framework for IIS

    link if any plz 

    so it may help others grappling with same issue

    Friday, December 20, 2013 9:30 PM