locked
Problem in getting WebcamExtensionCPP sample application to launch for Windows 8 Consumer Preview

    Question

  • Hi,

    I've problem in getting "Metro style device app for camera sample(WebcamExtensionCPP)" to work on my Windows 8 Consumer Preview system. Below are the screenshots for device metadata info for my camera device:

     

    Am I miss out anything? Any help or pointers will be greatly appreciated.

    BTW, I'm able to get developer preview version of  "Metro style device app for camera sample(WebcamDCACPP)" to work on Windows 8 Develop Preview OS previously.

    Tuesday, March 13, 2012 4:05 AM

Answers

  • The metadata is not signed, and there's an added check for it. I forgot about this, and I think this is the issue why it's not working. Can you try this?

    1. In an elevated command prompt, run 'bcdedit -set testsigning on'

    2. Reboot machine

    3. Uninstall the webcam and plug it in again

    Thanks, Yuenfai

    • Marked as answer by Lim Kok Ann Monday, March 19, 2012 7:42 AM
    • Unmarked as answer by Lim Kok Ann Monday, March 19, 2012 7:45 AM
    • Marked as answer by Lim Kok Ann Monday, March 19, 2012 7:47 AM
    Friday, March 16, 2012 9:07 PM

All replies

  • Hello,

    We have published updated instructions to go with the Consumer Preview and they are located here:

    http://msdn.microsoft.com/library/windows/hardware/hh454870

    Best Wishes - Eric

    Tuesday, March 13, 2012 8:24 PM
    Moderator
  • Hi Eric,

    Thanks for the reply.

    I've gone through the topic on "Associating your app with the camera" for this updated document. However, there is not much different from the previous one regarding about the association of camera device app with the external USB camera device using the Device Metadata Authoring Wizard.

    Wednesday, March 14, 2012 6:20 AM
  • Hi,

    I looked at the screenshots you posted and they look to be correct. After copying the metadata to the device metadata store, did you uninstall/rescan the webcam in device manager?

    Thanks, Yuenfai

    Wednesday, March 14, 2012 8:47 PM
  • Hi Yuenfai,

    I did uninstall the webcam through the device manager. After the uninstallation, I copy my device metadata file "d52454ce-7d4d-4298-88a1-0cfb600254f8.devicemetadata-ms" into the "C:\ProgramData\Microsoft\Windows\DeviceMetadataStore\en-US" folder and then plug in my webcame device. The OS seems aware of the present of my device metadata file as shown in the following screenshot:

    Thursday, March 15, 2012 1:47 AM
  • Few things to check:

    - I see that you have couple other metadata files there, is any one of them have the webcam hardware id?

    - Was the WebcamExtensionCPP sample app installed successfully and able to launch from Start menu?

    - What app are you using to launch the webcam settings?

    Thanks, Yuenfai

    Thursday, March 15, 2012 10:53 PM
  • - Yes, there are two device metadata files("b60dcb2a-0713-4c76-912b-e00c7a31d5b1.devicemetadata-ms" and "50a6876f-207d-4051-b0ac-d3878f898411.devicemetadata-ms") with different hardware IDs targeted for two different models of camera device.

    -  The WebcamExtensionCPP sample app able to launch from Start menu.

    - I'm using the bundled Camera app as well as the Camera Capture UI sample app to invoke the More camera option but all showing the default option UI instead of the one provided by the WebcamExtensionCPP sample app.

    Thanks, Kok Ann

    Friday, March 16, 2012 3:36 AM
  • The metadata is not signed, and there's an added check for it. I forgot about this, and I think this is the issue why it's not working. Can you try this?

    1. In an elevated command prompt, run 'bcdedit -set testsigning on'

    2. Reboot machine

    3. Uninstall the webcam and plug it in again

    Thanks, Yuenfai

    • Marked as answer by Lim Kok Ann Monday, March 19, 2012 7:42 AM
    • Unmarked as answer by Lim Kok Ann Monday, March 19, 2012 7:45 AM
    • Marked as answer by Lim Kok Ann Monday, March 19, 2012 7:47 AM
    Friday, March 16, 2012 9:07 PM
  • Hi Yuenfai,

    It's working now.

    Thanks, Kok Ann

    Monday, March 19, 2012 7:50 AM