locked
Application Lockup under Remote Desktop RRS feed

  • Question

  •  

    I have written a single instance application in VB.Net 2005.  It seems to go unresponsive when run under Remote Desktop and the workstation locks / screen saver activates do to inactivity.  RDP allows the application to run multiple instances under different sessions just fine (As it should).  Any Ideas?

    Tuesday, August 21, 2007 5:34 PM

Answers

  •  

    OK, I figured it out.

    I was not closing all of my open forms in a secondary thread.

    Friday, August 31, 2007 1:45 PM

All replies

  • Hi Karl,

     

    I’m not very sure about what you mean by “and the workstation locks / screen saver activates do to inactivity”, could you please clarify? What version of windows you are using?

     

    To troubleshoot this issue, we really need the source code to reproduce the problem, so that we can investigate the issue in house. It is not necessary that you send out the complete source of your project. We just need a simplest sample to reproduce the problem. You can remove any confidential information or business logic from it.

     

    Thanks for your understanding!

    Friday, August 24, 2007 8:22 AM
  • Hi Karl,

     

    We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.  

     

    Thank you!

    Monday, August 27, 2007 2:42 AM
  • Sorry for not getting back to you sooner.

    There are 9 projects in this solution. 

    I will try to provide a little more detail.

    Let me see if I can discover what steps to take inorder to reproduce the problem exactly.

    That will tell me what code to send to you.

     

    Thanks

    Wednesday, August 29, 2007 5:59 PM
  •  

    OK, I figured it out.

    I was not closing all of my open forms in a secondary thread.

    Friday, August 31, 2007 1:45 PM