locked
socialite log in problem

    Question

  • hi there, im currently testing the windows development preview and so far ive had no problems as yet. except for socialite.

    after entering my facebook log in details it seems to get stuck and continually displays the "logging in" message.

    does anyone else have/had this problem and if so, has anyone found a way to correct the problem?

    Friday, October 14, 2011 8:07 AM

Answers

  • Thanks for your feedback on Socialite – we are aware of this issue and it is impacting many of us here at Microsoft that love to use Socialite as well. Unfortunately anyone trying to login for the first time hits an error and cannot login. If you have logged in previously you should still be okay. We’re working out what has gone wrong and appreciate your patience as we figure out how to get you all back into Socialite.
    Tuesday, October 18, 2011 10:25 PM
  • If you are a new user and have never tried Socialite before, log on to Socialite on a different platform first and then log on to socialite on the Windows 8 Developer Preview.

    If you have used Socialite in the past and are still having a problem, keep updated on the Facebook page of Socialite:

     http://www.facebook.com/apps/application.php?id=171463892915039

    Microsoft Have reviewed this problem and are working hard to try and fix it.


    Saturday, October 22, 2011 8:40 AM

All replies

  • I am seeing the same thing and it was working fine up to a day or 2 ago, I've even gone as far as to reinstall, still the same problem.
    Friday, October 14, 2011 9:45 AM
  • i think it may have been one of the microsoft updates affected it in some way. im going to try and uninstall all updates then re-install them one by one to see what one has done the dirty deed.
    Friday, October 14, 2011 10:11 AM
  • i think it may have been one of the microsoft updates affected it in some way. im going to try and uninstall all updates then re-install them one by one to see what one has done the dirty deed.
    ok... so ive uninstalled all updates and its still stuck on "loging in" . any other ideas why this is failing to connect to facebook?
    Friday, October 14, 2011 10:32 AM
  • Same problem here :/

    Friday, October 14, 2011 9:45 PM
  • Uncle Bill Gates give us an answer!! we can't use this app well....fix it please 
    Friday, October 14, 2011 11:00 PM
  • you'd think they'd at least acknowledge, oh well
    Saturday, October 15, 2011 12:05 AM
  • Same here. Sad because it's the one app I show off when demoing the tablet to others.
    Thanks,
    Bobby Cannon
    BobbyCannon.com
    Saturday, October 15, 2011 12:30 AM
  • Worked fine until a few days ago. 

    I may have logged out and can not successfully log back in.

    Saturday, October 15, 2011 2:58 AM
  • Same here...Socialite no longer working.  There's a ton of people complaining Socialite breaking on it's Facebook page as well.

    Saturday, October 15, 2011 3:01 AM
  • They may wanna fix this ASAP
    Saturday, October 15, 2011 3:45 AM
  • any comments from the dev team???   silence is definitely not golden.
    Saturday, October 15, 2011 9:22 AM
  • oh well, i guess they aren't interested!. 
    Saturday, October 15, 2011 5:38 PM
  • It is the weekend so....
    Saturday, October 15, 2011 6:02 PM
  • I've just got myself an IconiaTab to play with the 8 Preview, and Socialite was the first thing I wanted to try using with multi-touch. It was the coolest of all the demo apps. Is it really dead? :(

    Sunday, October 16, 2011 12:10 AM
  • At the moment it's dead. Log in never completes with the progress bar endlessly looping here. Friend's posts have stopped showing on my wall though that may not be related to Win8 and Socialite but simply coincidental.

     

    I've upgraded Adobe Flash and made sure HTTPS was disabled in Facebook per a user's suggestion but no change in the problem(s) 


    Sunday, October 16, 2011 1:51 AM
  • Having the same issue here.  Wonder when there will be a fix for it.
    Tuesday, October 18, 2011 8:37 PM
  • Good question, I performed a "refresh" last night and tried to login after getting home from work tonight and I'm still getting the never-completing login "loop". 
    Tuesday, October 18, 2011 10:01 PM
  • Thanks for your feedback on Socialite – we are aware of this issue and it is impacting many of us here at Microsoft that love to use Socialite as well. Unfortunately anyone trying to login for the first time hits an error and cannot login. If you have logged in previously you should still be okay. We’re working out what has gone wrong and appreciate your patience as we figure out how to get you all back into Socialite.
    Tuesday, October 18, 2011 10:25 PM
  • Thanks for the reply Edgar!

    Tuesday, October 18, 2011 11:55 PM
  • thanks for your reply :-)
    Wednesday, October 19, 2011 11:22 PM
  • I have the same issues here, tried all of the above to no avail, it's a shame because this was a good demo app.

    Thursday, October 20, 2011 6:51 AM
  • same problem i have login loop too and login loop and login loop . .  .
    Thursday, October 20, 2011 12:05 PM
  • If you are a new user and have never tried Socialite before, log on to Socialite on a different platform first and then log on to socialite on the Windows 8 Developer Preview.

    If you have used Socialite in the past and are still having a problem, keep updated on the Facebook page of Socialite:

     http://www.facebook.com/apps/application.php?id=171463892915039

    Microsoft Have reviewed this problem and are working hard to try and fix it.


    Saturday, October 22, 2011 8:40 AM
  • If you are a new user and have never tried Socialite before, log on to Socialite on a different platform first and then log on to socialite on the Windows 8 Developer Preview.

    If you have used Socialite in the past and are still having a problem, keep updated on the Facebook page of Socialite:

     http://www.facebook.com/apps/application.php?id=171463892915039

    Microsoft Have reviewed this problem and are working hard to try and fix it.


    Different platform, like which?
    Sunday, October 23, 2011 5:15 PM
  •  

    I have the same issue and I want to ask the same question... what different platform?? Where do I have to login to avoid the issue?

     

     

    Thursday, November 10, 2011 9:00 PM
  • Thanks for your feedback on Socialite – we are aware of this issue and it is impacting many of us here at Microsoft that love to use Socialite as well. Unfortunately anyone trying to login for the first time hits an error and cannot login. If you have logged in previously you should still be okay. We’re working out what has gone wrong and appreciate your patience as we figure out how to get you all back into Socialite.

    ok, I'll try this

    and this

    If you are a new user and have never tried Socialite before, log on to Socialite on a different platform first and then log on to socialite on the Windows 8 Developer Preview.
    
    If you have used Socialite in the past and are still having a problem, keep updated on the Facebook page of Socialite:
    
     http://www.facebook.com/apps/application.php?id=171463892915039
    
    Microsoft Have reviewed this problem and are working hard to try and fix it.


    Sunday, November 13, 2011 3:39 AM
  • I'm having the same problem with the Socialite App, so I ran it through the Windows App Certification Kit see results below.


    Windows App Certification Kit Test Results
    Application Name: microsoft.socialite
    Application Version: 1.0.0.31
    Application Publisher: CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US
    Report Generation Time: 17/11/2011 10:21:29

    --------------------------------------------------------------------------------

    Overall Score: PASSED WITH WARNINGS

    --------------------------------------------------------------------------------

    Eliminate Application Failures

    PASSED Do not install executables that crash or hang during the testing process

    Metro style App Test Failure

    PASSED Metro style App manifest must include valid entries for all required fields

    Opt into Windows security features

    PASSED Binary Analyzer

    Use of Supported Platform APIs

    PASSED Supported APIs

    Launch time performance

    WARNING Performance Launch
    Warning: Following errors were encountered while running the Performance Launch test.
    Application Error:Launch stop was not detected for application id Socialite.App.
    Application Error:Private pages size of 80.324 exceeded performance maximum of 25 megabytes for application id Socialite.App.
    Impact if not fixed: Your application exhibits poor launch performance by taking a long time to launch and/or consuming significant amount of resources (% CPU utilization, File I/O, Memory usage). This may negatively impact the user experience when multitasking between applications. Reducing resource utilization during launch can improve launch times especially when contention for resources is high.
    How to fix: TBD.

    Suspend performance

    WARNING Performance Suspend
    Warning: Following errors were encountered while running the Performance Suspend test.
    Application Error:Suspend stop was not detected for application id Socialite.App.
    Impact if not fixed: Your application exhibits poor suspend transition performance by taking a long time to respond to the quiesce notification and/or consuming significant amount of resources (% CPU utilization, File I/O). This may negatively impact the user experience when multitasking between applications. Reducing resource utilization during launch can improve suspend times especially when contention for resources is high.
    How to fix: TBD.

    Test Appx Manifest Resources

    PASSED Appx Manifest Resources Validation

    .NET version check

    PASSED .Net Framework Check

    Would the 2 warning have any affect on the App, it does say Impact if not fixed on both  of them 

     

    Thursday, November 17, 2011 10:42 PM
  • If you are a new user and have never tried Socialite before, log on to Socialite on a different platform first and then log on to socialite on the Windows 8 Developer Preview.

    If you have used Socialite in the past and are still having a problem, keep updated on the Facebook page of Socialite:

     http://www.facebook.com/apps/application.php?id=171463892915039

    Microsoft Have reviewed this problem and are working hard to try and fix it.


    Different platform, like which?

    Indeed... Like which different platform? Can I download Socialite for windows 7 somewhere ? of for the iphone?
    Tuesday, November 29, 2011 11:32 PM
  • how time we need to wait to fix that problem  ?
    Sunday, December 11, 2011 10:03 AM
  • If you are a new user and have never tried Socialite before, log on to Socialite on a different platform first and then log on to socialite on the Windows 8 Developer Preview.

    If you have used Socialite in the past and are still having a problem, keep updated on the Facebook page of Socialite:

     http://www.facebook.com/apps/application.php?id=171463892915039

    Microsoft Have reviewed this problem and are working hard to try and fix it.


    Different platform, like which?
    Like to know as well. A little more info on a possible workaround would be highly appreciated. Right now, you get the feeling that there are possibilities, but nobody knows how? Otherwise just tell us when the bug is fixed.
    Sunday, December 11, 2011 1:34 PM
  • in the dmp file i was see that error

            <tr>
                            <td class="contentPaneSpace"><td>
                            <td class="contentPaneText">
                                <div id="genericError" class="description">
                                    <h1 id="genericErrorTitle">Oops. We have a bit of a problem.</h1>
                                    <div class="text">
                                        <p id="genericErrorDescription"><span class="displayname"></span> has encountered an error (<span class="code"></span>). You can try re-launching the app or post feedback to <span class="displayname"></span>'s developers in the Windows App Store so they can fix the problem.</p>
                                    </div>
                                </div>
                                <div id="connectionError" class="description">
                                    <h1 id="connectionErrorTitle">Oops. We need to use the internet.</h1>
                                    <div class="text">
                                        <p id="connectionErrorDescription">Your internet connection has been lost which means <span class="displayname"></span> cannot work correctly. You can go to network settings to connect to a different network.</p>
                                    </div>
                                </div>
                                <div id="contentError" class="description">
                                    <h1 id="contentErrorTitle">Oops. We cannot display that content.</h1>
                                    <div class="text">
                                        <p id="contentErrorDescription"><span class="displayname"></span> has encountered an error (<span class="code"></span>). You can try going back or posting feedback to <span class="displayname"></span>'s developers in the Windows App Store so they can fix the problem.</p>
                                    </div>
                                </div>

    Monday, December 12, 2011 10:49 PM
  • Can you plz tell wen will dis problem be resolved
    Sunday, December 25, 2011 6:10 AM
  • Please users - be patient. This is not a production operating system, not even a beta. In theory, it is not even intended for the general public, although many non-developers seem to have downloaded it and are using it.

    This is a good thing, but let's be aware of the status of this system. Rumor has it that the beta will be available towards the end of February. Let's see what that looks like.

    In the meantime, keep an eye on this thread - one never knows...


    Gateway laptop Windows 7 Professional SP1
    Monday, January 02, 2012 11:11 PM
  • Dear blegs38552,
    You're right but that isn't an OS problem, the problem is with app, isn't it?
    Are there any plans to fixing it, time has passed since October and still there are no results. Have they stopped developing the app?
    Thanks.

    Well this is the world we live in And these are the hands we're given...
    Thursday, January 19, 2012 11:31 AM
  • ok guys, Beta is in in a few weeks, and STILL no resolution OR update on the situation. this is pretty poor customer support.

    at what point do you decide that NO update for 5 months is the right course of action. any update, even if it's just 'we still have no resolution' is better then silence.

    Friday, February 17, 2012 6:27 PM
  • If you are a new user and have never tried Socialite before, log on to Socialite on a different platform first and then log on to socialite on the Windows 8 Developer Preview.

    If you have used Socialite in the past and are still having a problem, keep updated on the Facebook page of Socialite:

     http://www.facebook.com/apps/application.php?id=171463892915039

    Microsoft Have reviewed this problem and are working hard to try and fix it.



    can you please show where you can log into socialite on a diffrent platform?
    Friday, February 17, 2012 6:29 PM
  • @iwashuman2021 Word! I can't find any platform??
    Sunday, February 19, 2012 1:30 AM
  • Okay, thanks to this page, I managed to make the Socialite working for me.

    My Italian is even worse than my English, but thankfully I don't need to write in it (although I would really love to learn it).

    Here's my re-writing of the provided instruction.

    The key to enabling the Socialite app is patching. To get the stalled log-in problem fixed, you need to fix the Jscript file used by Socialite and manually fill the following authentication properties:

    • currentUserId
    • currentUserAccessToken

    IMPORTANT! Please be warned that this operation is HIGHLY INSECURE and I DO NOT SUGGEST YOU FOLLOW IT IN ANY WAY. Following these steps you may put your account security AT RISK. This operation involves using your TOKEN. Exposed tokens POSE HIGH SECURITY RISKS. DO THIS AT YOUR OWN RISK!


    1. Logon into the system with administrative privileges. Alternatively, you may just start Windows Explorer under a user account with administrative . This is only necessary to take ownership on the app folder.

    2. Open the program folder %ProgramFiles% and locate the Applications folder. This is a hidden folder and you may not see it if showing hidden files and folders is not enabled in your system.

    To show hidden files and folders, switch to the View tab in the Windows Explorer's ribbon and set the Hidden items checkbox in the Show/hide group.

    3. Right-click the %ProgramFiles%\Applications folder, choose Properties, and switch to Security tab.

    On the Security tab click Advanced and click Change link next to the Owner to take ownership. Confirm UAC request and type your user account name in the Enter the object name to select (examples) box within the Select User, Computer, Service Account, or Group dialog box. Click OK to add your user account. Notice that your account is now listed next to Owner in the Advanced Security Settings for %FOLDERNAME% dialog box.

    4. Set the Replace all child object permissions with inheritable permissions from this object checkbox to make yourself the owner of all subfolders. (You skip this step and set this only for the Socialite's app folder at a later time).

    5. Navigate to %ProgramFiles%\Applications\microsoft.socialite_1.0.0.31_neutral_neutral_8wekyb3d8bbwe\js\ folder and locate the Socialite.js script file.

    6. Select the script file, press Ctrl+C, then Ctrl+V to make a backup copy of this file. To be on the safe side, give the file a .bak extension.

    7. Right-click the Socialite.js script and choose Edit to open the file for editing in Notepad.

    8. In the Notepad opened locate the following line:

    Socialite.currentUserId = Socialite.Storage.getValue

    9. In the following steps, we are going to change the code block:

     

    Socialite.currentUserId = "";
    Socialite.currentUserAccessToken = "";
    Socialite.currentUserId = Socialite.Storage.getValue(Socialite.Constants.facebookUserIdKey);
    Socialite.currentUserAccessToken = Socialite.Storage.getValue(Socialite.Constants.facebookUserAccessTokenKey);

    10. Retrieve your Facebook User ID, which you need to place between the quotes in the

    Socialite.currentUserId = "";

    line.

    To do that, open your Facebook page in your browser and locate your user name in the URL used to access your page (like yournickname for the URL http://www.facebook.com/yournickname). Paste the yournickname after the http://graph.facebook.com/ and navigate the URL (that is open the http://graph.facebook.com/yournickname address in your browser). Your browser will prompt for downloading a Jscript file. The script will have yournickname as its file name, like yournickname.js

    Save this script to a location and open it in the Notepad. In the Notepad locate the ID like

    {   "id": "12345",    "name":

    Copy the number in quotes. Return back to the Notepad window with Socialite.js script and paste the copied number as the value of the currentUserId property, like:

    Socialite.currentUserId = "12345";

    Press Ctrl+S to save changes to Socialite.js

    11. Retrieve your Facebook token, which you need to place between the quotes in the

    Socialite.currentUserAccessToken = "";

    line.

    WARNING: THIS REQUEST RETURNS YOUR TOKEN, THAT IS YOUR ENCODED PASSWORD. THE TOKEN IS RETURNED IN PLAIN TEXT.

    !IMPORTANT: I DON'T KNOW WHAT THE VALUE OF THE client_id PARAMETER IS! Obviously, it's a 15-digit Facebook userID, but WHOS ID THIS IS?

    (Is it an ID of the Socialite app on Facebook?)

    To retrieve the token, open the following page in your browser (https://www.facebook.com/dialog/oauth?response_type=token&display=popup&client_id=171463892915039&redirect_uri=https%3A%2F%2Fwww.facebook.com%2Fconnect%2Flogin_success.html&scope=user_photos,read_stream,publish_stream,user_checkins,publish_checkins,friends_checkins,offline_access,status_update)

    This should substitute for the URL like: https://www.facebook.com/connect/login_success.html#access_token=HEREGOESYOURTOKEN&expires_in=0 after being executed in the address bar. The page will show Success.

    Copy the alpha-numeric string between the #access_token= and &expires_in from the URL returned to the address bar (https://www.facebook.com/connect/login_success.html#access_token=HEREGOESYOURTOKEN&expires_in=0). This is your token.

    Return back to the Notepad window with Socialite.js script and paste the copied string as the value of the currentUserAccessToken property, like:

    Socialite.currentUserAccessToken = "HEREGOESYOURTOKEN";

    Press Ctrl+S to save changes to Socialite.js

    12. Comment out the line in the Socialte.js that retrieves your FaceBook ID, facebookUserIdKey, (because we have already specified your ID right in script):

          // Socialite.currentUserId = Socialite.Storage.getValue(Socialite.Constants.facebookUserIdKey);

    Press Ctrl+S to save changes to Socialite.js


    13. Comment out the line in the Socialte.js that retrieves your FaceBook token, facebookUserAccessTokenKey, (because we have already specified your token right in script):

     // Socialite.currentUserAccessToken = Socialite.Storage.getValue(Socialite.Constants.facebookUserAccessTokenKey);

    Press Ctrl+S to save changes to Socialite.js

    14. Close the Socialite.js and run the Socialite app. The app should now automatically log into your Facebook account without prompting you for your credentials.


    • Proposed as answer by Exotic Hadron Tuesday, February 21, 2012 5:46 PM
    • Edited by Exotic Hadron Wednesday, February 22, 2012 9:47 AM
    Tuesday, February 21, 2012 5:46 PM
  • Argh, paste nightmare! How do you get this paste to work in IE10? I was writing this text in OneNote, then I pasted it into the Post form on the forum and the whole text went funky, all formatting has disappeared. I'll try to edit the posted message, but please fix forum scriping!

    A note for moderators: I am sorry to post a message with broken formatting but that what it gets like in IE10. I am hoping to resolve this tomorrow when I am back. Please beg my excuse. I would appreciate if you could hand over this informaition to site/browser developers.

    Thank you.


    Well this is the world we live in And these are the hands we're given...



    Tuesday, February 21, 2012 5:48 PM