Problem after Xamarin update RRS feed

  • Question

  • User117981 posted

    Hi there After Xamarin update I cannot deploy the app to device (it builds Ok though):

    Java.Lang.RuntimeException: Unable to instantiate activity ComponentInfo{SSCApp.Droid/md5983104ebd031e37969f76a111125273a.MainActivity}: java.lang.ClassNotFoundException: Didn't find class "md5983104ebd031e37969f76a111125273a.MainActivity" on path: DexPathList[[zip file "/data/app/SSCApp.Droid-1/base.apk"],nativeLibraryDirectories=[/data/app/SSCApp.Droid-1/lib/arm, /vendor/lib, /system/lib]]

    What can cause that?

    My Visual Studio info:

    Xamarin (2a34af5) Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

    Xamarin Designer 4.8.183 (2577c82ea) Visual Studio extension to enable Xamarin Designer tools in Visual Studio.

    Xamarin.Android (f241f51) Visual Studio extension to enable development for Xamarin.Android.

    Xamarin.Android SDK (HEAD/5d942bd12) Xamarin.Android Reference Assemblies and MSBuild support.

    Xamarin.iOS (6857dfc) Visual Studio extension to enable development for Xamarin.iOS.

    Xamarin.iOS and Xamarin.Mac SDK (6857dfc) Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.


    Tuesday, December 12, 2017 10:02 PM

All replies

  • User363257 posted

    I'm having a similar Issue.

    I am unable to Deploy my Android Application, builds fine.

    When deploying I received The following error: Error: android.view.InflateException: Binary XML file line #28: Error inflating class ...

    also this error occurred java.lang.classnotfoundexception didn't find class on path dexpathlist

    All errors came about when adding a Third party Library like RoundedImageView or the CircleImageView by James Montemagno.

    UPDATE* This issue after 3 hours of continuously receiving the error and looking into MultiDex and rabbit holing resolved by itself. (Ahh Yes the magical "It Works, and I don't know why")

    The only change I did was disconnected all Devices from my laptop waited for about 30 minutes and tried to deploy and it worked.

    Not sure what the deal is as right now as my resolution is Magical( I am able to use the Third Part Libraries as well).

    Wednesday, December 13, 2017 9:47 PM
  • User312309 posted

    Same problem here too, really frustrating. Leaving me clueless..

    Friday, December 15, 2017 11:47 AM
  • User269076 posted

    I have the same problem on Visual Studio 15.5.2.

    Friday, December 15, 2017 12:44 PM
  • User297045 posted

    I am having the same problem. If someone figures this out, please post a fix. 15.5.2 also.

    Friday, December 15, 2017 8:30 PM
  • User362403 posted

    I have the same problem, I even asked a question about it but nobody answered it... I hope we can find a solutionI

    Friday, December 15, 2017 9:41 PM
  • User109485 posted

    I have similar issue with error when deploy/lanuch App:

    Java.Lang.RuntimeException: Unable to get provider md562a154ca8772b4a36eb2b02ddfba4e36.ClevestFileContentProvider: java.lang.ClassNotFoundException: Didn't find class "md562a154ca8772b4a36eb2b02ddfba4e36.ClevestFileContentProvider" on path: DexPathList[[zip file "/data/app/smartdeviceapp.smartdeviceapp-1/base.apk"],nativeLibraryDirectories=[/data/app/smartdeviceapp.smartdeviceapp-1/lib/arm, /vendor/lib, /system/lib]]

    It was working fine in VS 2015; it happened when I upgrade to VS 2017 15.5 or version 15.0.

    Friday, December 15, 2017 10:58 PM
  • User13824 posted

    Bugzilla cross-reference

    Saturday, December 16, 2017 2:26 AM
  • User187134 posted

    I am getting this to.

    Saturday, December 16, 2017 8:13 AM
  • User360562 posted

    I am having the same issue while trying to set up the newly released reference App - SmartHotel360 demoed in Connect 2017.

    My emulators are going blank after switching between turning Hyper-V on and off to run Docker for compiling backend APIs.

    I am not sure how the roadmapping is going to work when basic UI creation and emulators are in such a broken state.

    I am new to Xamarin - and spending most of the time to get the base environment under control before even learning the details of Xamarin Forms.

    Tuesday, December 19, 2017 5:32 PM
  • User117981 posted

    Hi there It looks like I fixed it making use of the link provided by BrendanZagaezki (see above). It mentions on assembly version notation so as soon as I switched from “1.1.*” to a specific “” (for Android part of my "Forms" project) it begun working. As the versioning is not critical, I consider it as a viable workaround for me. Thanks.

    Tuesday, December 19, 2017 6:17 PM
  • User255059 posted


    Tuesday, December 19, 2017 8:04 PM
  • User109485 posted

    it is working now when I change from [assembly: AssemblyVersion("6.0.*")] to [assembly: AssemblyVersion("")]. is our product release number.

    This comment about assemblyVersion: // Version information for an assembly consists of the following four values: // // Major Version // Minor Version // Build Number // Revision // // You can specify all the values or you can default the Build and Revision Numbers // by using the '*' as shown below:

    Tuesday, December 19, 2017 10:10 PM
  • User218392 posted

    I also getting. My menifest

            <activity android:name=".SplashActivity" android:label="someName" >
                    <action android:name=".SplashActivity" />
                    <category android:name="android.intent.category.DEFAULT" />


    public class SplashActivity : AppCompatActivity


    Java.Lang.RuntimeException: Unable to instantiate activity ComponentInfo{com.sisapp.in.sisapp/com.sisapp.in.sisapp.SplashActivity}: java.lang.ClassNotFoundException: Didn't find class "com.sisapp.in.sisapp.SplashActivity" on path: DexPathList[[zip file "/data/app/com.siredp.in.siredp-1/base.apk"],nativeLibraryDirectories=[/data/app/

    How to solve it

    Wednesday, December 20, 2017 3:29 PM
  • User255059 posted

    You can always rollover your Visual Studio/Xamarin version


    Wednesday, December 20, 2017 5:44 PM