none
On Screen Keyboard not working in Custom Shell, Windows 10 Pro 1709 and 1803 RRS feed

  • Question

  • Hi,

    We are using the On Screen Keyboard in Windows 10 Pro for our Custom Shell application.

    Since release 1607 and for 1703 the registry setting "EnableDesktopModeAutoInvoke" in "HKCU\SOFTWARE\Microsoft\TabletTip\1.7" set to DWORD=1 has provided the On Screen Keyboard for the user running the application, but since relase 1709 this is not working anymore. I have also tried latest 1803 relase with the same negative result.

    What have changed in the 1709 (and 1803) release?

    Is this "by design" or a mistake?

    Is there any other solution than the registry setting that can help us out here? The 1703 support is ending fall 2018.

    Thanks.

    Thursday, March 22, 2018 6:54 AM

All replies

  • Hello,

    We are having the same issue and have found that running any shell other than Explorer in 1709 causes the touchscreen keyboard to not appear.  We are just trying to run a simple kiosk setup using IE and since upgrading our SOE to the latest feature update of Windows, I'm having to re-engineer the solution entirely.  I've been hoping that another round of Windows updates may resolve the issue, but it seems that the March CU hasn't made a difference either.

    I've tried using the inbuilt ShellLauncher feature, but it suffers from the same pitfalls.  I'm now looking at toying with the assigned access feature and an app from the Windows Store called Kiosk SP browser.  But at the outset it looks like a bit more manual intervention to get set up as I'd like to have as much as I can standardized using Group Policy and scripting where necessary so it's just a matter of imaging a machine and dropping into the right OU.

    Does anyone have any suggestions on how to get around this or found a solution to this annoying keyboard issue?  I've tried all of the various registry settings as above in addition to some others, but no luck.  Any feedback or suggestions would be much appreciated.  

    Thanks

    ***Update***

    The assigned access scenario has been tested and doesn't work either!

    Thursday, March 22, 2018 10:49 PM
  • Ping!

    Anyone having a possible solution for this, or that knows about an upcoming fix?

    Tuesday, March 27, 2018 8:40 AM
  • Hi,

    We have the same issue with 1803 (and 1709), did you find any solution or workaround to this problem?

    We have tried everrything we could think of, but it looks like the explorer has to be started to get the keyboard working.

    Thanks

    Johan

    Monday, June 11, 2018 1:00 PM
  • Hi,

    No, but I have not had the time to investigate this since March.

    I guess something when broken (by purpose?) when new Ease of Access-features was introduced in 1709, or this was removed as a custom shell feature which is crap. Have you tried with Enterprise edt?

    Monday, June 11, 2018 1:16 PM
  • Hi, thanks for the quick reply.

    No, we haven't tried with Enterprise, we have a lot of Pro machines deployed that really need this functionality.

    We also tried to configure Assigned Access with no success. Only option so far is to keep them on 1703.

    I really don't understand why MS intentionally would break the basic functionality of the On Screen Keyboard.

    Tuesday, June 12, 2018 6:14 AM
  • Hi again,

    Where can I raise a ticket for this issue to be investigated and resolved?

    Wednesday, July 4, 2018 6:37 AM
  • We have been experiencing the same issue and I submitted an MSDN support incident for this.

    I will update here if and when I get something useful back.

    We have tested the latest OS update (KB4284848) and the issue still exists.

    Monday, July 9, 2018 3:24 PM
  • Try the following:
    • Select key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TabletTip\1.7]
    • Create value [New] ⇒ [DWORD (32 bit) value] 
    • Change the value name to [DisableNewKeyboardExperience] 
    • Change the name [DisableNewKeyboardExperience] Double-click to open the value data, change it to 1
    •  Restart the PC 

    Source:

    https://answers.microsoft.com/ja-jp/windows/forum/windows_10-start-win_touchkey/windows10-fall-creators-update/42392945-f037-46f7-9cfe-d49c339994ef?auth=1

    Regards


    • Edited by Geevo Monday, July 23, 2018 6:44 PM
    • Proposed as answer by Ben107 Tuesday, July 24, 2018 3:04 PM
    Monday, July 23, 2018 6:44 PM
  • Thank you TechNutta! 

    The solution worked perfectly for us.

    Johan

    Thursday, July 26, 2018 9:26 AM
  • Your solution fixes my headache... million thanks!!
    Thursday, July 26, 2018 12:50 PM
  • This was it ! You just saved myself a ton of time ! Thank you very much !!!
    Wednesday, September 19, 2018 8:31 AM