locked
500 server error RRS feed

  • Question

  • User-501623949 posted

     Hi every one ...

     

    i work on iss server for long time and i browsing and programming with asp classic 

     

    but in last few dayes when i request any page or when i request the localhost page it's displayed error page like :

     

    500 server error 

    Server Error

    The following error occurred:

    [code=SERVER_RESPONSE_CLOSE] The server closed the connection while reading the response. Contact your system administrator.


    Please contact the administrator.

     

    i used windows xp sp3

    (note : i didn't try to install apatchi server for php language)

    please help me if you can .....

     

    thank you 

     

    Monday, October 12, 2009 1:41 AM

Answers

  • User-501623949 posted

     thank you for every one

    i find the solve for my problem by  repairing the windows from windows cd

     

    thank you 

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, October 19, 2009 2:10 AM

All replies

  • User157784788 posted

    What page you are trying to browse? is it ASP or php?

    Did you check IIS logs for any details?

    ~ Ganesh

    Monday, October 12, 2009 6:01 AM
  • User-501623949 posted

     thank you for your replay

     

    i use ASP pages As classic ASP 

    with XP PRO sp3

     i tried to do these points to solve the problem but nothing done :

     

    1. i uninstall IIS and rebooted the system and reinstall the IIS but nothing.
    2. i tried to turn on the  Default Web Site (Stopped) from Contol Panel --> Administrative Tools --> Internet Information Services but it not accepted.
    3. i tried to start the www service from the services but appear error message there are error parameters .
    4. i tried to reinstall the Win XP SP3 but nothing done.

    i behiend same this problem previase but i solved that by formated the pc.

    please tell me who i can solve this problem without format ??????

     

    thank you very much  .....

    Monday, October 12, 2009 7:15 AM
  • User157784788 posted

    You don't need to format the PC :)

    Can you browse the site locally on the PC like http://localhost/default.asp

    Does that work?

    ~ Ganesh

     

    Monday, October 12, 2009 7:24 AM
  • User-501623949 posted

     it is Does that work?

     

    and the event log says :

    The World Wide Web Publishing service terminated with the following error:
    The parameter is incorrect.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Monday, October 12, 2009 8:56 AM
  • User-501623949 posted

     No any one can solve this issue

    Tuesday, October 13, 2009 5:16 AM
  • User-501623949 posted

     i can't believe 482 views and no any help up to now

    Tuesday, October 13, 2009 7:45 AM
  • User-823196590 posted

    So what is the problem at this point? 

    Please be specific, copy and paste the exact/full error message and indicate what URL you are browsing to.  If it's for an ASP page, what does the ASP code do?

    Tuesday, October 13, 2009 11:46 AM
  • User-501623949 posted

     Thank you for your replay

     

    the problem not with the code in the asp pages i used this pages every day for 6 months with out any mistakes 

    but now the issue was with the sever that is operate these pages the iss not work normally when i request the http://localhost page it's giveen me "500 server Error"

     

    and www service not work and given me "There are parameters error"

     

    please follow the previous scenarios for more detailes about this issue

     

    thank you 

    Wednesday, October 14, 2009 1:00 AM
  • User-501623949 posted

     No any one have same problem before

    Wednesday, October 14, 2009 5:16 AM
  • User157784788 posted

    The World Wide Web Publishing service terminated with the following error:
    The parameter is incorrect.

    Seems IIS is not installed correctly. Can you uninstall IIS and reinstall it back from add/remove programs?

    ~ Ganesh

     

    Wednesday, October 14, 2009 5:50 AM
  • User-823196590 posted

    Could be a corrupt IIS metabase.  After you uninstall IIS, make sure you remove the inetsrv folder under C:\windows\system32.  You do not want the corrupt metabase to remain when you do the re-install.

    Wednesday, October 14, 2009 7:28 AM
  • User-501623949 posted

     thank you for your replay

     

    i tried  to delete inetsrv folder but i can't i deleted the files inside and i deleted the folder from the sfe mode its deleted but when i lunch the normal mode of windows i found this folder without any files and i installed the iss again but same problem occure

     

     

    Saturday, October 17, 2009 3:41 AM
  • User-501623949 posted

     to display the browser errors as image

    please follow this pictures:

     

     

     

     

    Saturday, October 17, 2009 5:53 AM
  • User-501623949 posted

     up

    Sunday, October 18, 2009 2:35 AM
  • User-501623949 posted

     thank you for every one

    i find the solve for my problem by  repairing the windows from windows cd

     

    thank you 

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, October 19, 2009 2:10 AM