locked
WebDAV Mini Redirector & Mapping to a drive RRS feed

  • Question

  • User-1585959952 posted

    After having spent a week on this matter, I have come to a conclusion that I need more detailed explanation on how to set up WebDAV Mini Redirector because it is just not working after having tried for a week.

    By following the instructions given from this site, I simply enabled WebClient through "Services", and then mapped my WebDAV folder to a network drive, say Z:/, either through My Computer-->Map a Network Drive or through NET USE * command.

    If I use a path that begins with http://, I get either "System error 67 has occurred." or prompted for userid/password that produces "System error 5 has occurred." once and then back to "System error 67 has occurred."

    If I use a UNC path that begins with \\, drive mapping gets done, but this is not a mapping that enforces WebDAV protocol, it's just intranet share through NetBIOS, and that's why the log did not pick up any WebDAV (HTTP) protocol.

    Can I get some explanation on how to distinguish between these two situations and enable WebDAV protocol properly?

    I have wasted so much time already and would really like a clarification on this issue.

    Thank you.

    Monday, April 18, 2011 2:12 PM

All replies

  • User744767459 posted

    Hi,

    1. When attempting to map a drive to a WebDAV site, you receive the following error:

    System error 67 has occurred.

    The network name cannot be found.

    This can be caused by one of the following conditions:

    • IIS is not installed or is not running on the server that you are attempting to connect to.
    • You have not installed the WebDAV Redirector on your client system.
    • The WebClient service is not running on your client system.
    • You have not enabled WebDAV on your web site.
    • You are using Basic Authentication and connecting to your web site using HTTP instead of HTTPS.
    • You are connecting to a web site on your local network that is using Fully-Qualified Domain Names (FQDNs) for name resolution, your web site uses Windows Authentication, and you have not added the web site's FQDN to the proxy server bypass list on your client.

    For more information about using WebDAV Redirector, please refer to:

    Using the WebDAV Redirector

    http://learn.iis.net/page.aspx/386/using-the-webdav-redirector/

    If your problem persists, please update here. Thanks. 

    Wednesday, April 20, 2011 2:19 AM
  • User-1585959952 posted

    Hi Leo,

    Thank you for your reply.

    Before I posted the question, I had already gone over the site a few times.

    None of the conditions is applicable but the last condition caught my attention.

    "You are connecting to a web site on your local network that is using Fully-Qualified Domain Names (FQDNs) for name resolution, your web site uses Windows Authentication, and you have not added the web site's FQDN to the proxy server bypass list on your client."

    We are not using any proxy server so I do not believe this is applicable either, but if so, where is the proxy server bypass list?

    Thanks,

    Wednesday, April 20, 2011 10:46 AM
  • User-1585959952 posted

    It has been over a week, and I wonder if I can get any reply on this.

    Don't know why this "supposed to be simple" thing does not work and why there is no simple fix to it.

    Thank you.

    Thursday, April 28, 2011 10:30 AM
  • User1138193213 posted

    Even if you are not using a proxy server, FQDNs work differently than short network names, and FQDNs can cause problems when you are using Windows authentication. While that may seem strange, here's the issue - when a dot appears in a network address, and that can be either in the form of "foobar.corp.contoso.com" or "192.168.0.1", the network stack assumes that it is an Internet address (and therefore not a local address) and treats it differently, even though the address is actually a local address.

    When you are using a proxy server, you can open the Internet Options applet in the Windows Control Panel, click the Connections tab, click the LAN settings button, click the Advanced button, and then enter any addresses that Windows should treat as a local address in the Exceptions text box.

    If you have no proxy server defined at all, then things get a little strange, because the Advanced button will be disabled in the LAN settings dialog box, which leaves you with two options:

    • If you are using FQDNs like "foobar.corp.contoso.com", you will need to use only the short name from the FQDN. For example, you would have to use "foobar" instead of "foobar.corp.contoso.com."
    • You will not be able to use the IP address, so you will have to use the short name that points to the IP address. For example, if "foobar" pointed to the IP address "192.168.0.1," you would have to use "foobar" instead of the IP address.
    Sunday, May 8, 2011 12:35 PM