locked
Cannot create a new C++ Win32 Smart Device project RRS feed

  • Question

  • Hi all:

    Using:  MS V.Studio 2008 Professional Edition Version 9.0.30729.1 SP
    .NET Framework version 3.5 SP1
    Windows XP Professional Version 5.1.2600 Service Pack 3 compilation 2600

    No problem to create a new C# Smart Device project, but when try to create a new Visual C++ > Win32 Smart Device project, silently abort with the nasty error "Creating project <xxxx>... project creation failed".

    At the same time, the Event Viewer show this warning:
        Event source:    Visual Studio - VsTemplate
        User:        No disponible
        Description:    One or more templates do not match any installed project packages.

    Of course I googled a lot for some solution, but for the moment without success. Between some others:

    *  How to deal with “Project creation failed…” problem of Visual Studio 2008
    http://developerspoint.wordpress.com/2008/06/25/how-to-deal-with-project-creation-failed-problem-of-visual-studio-2008/

    *  Can't add new projects or anything... "Creating project 'Test'... project creation failed."
    http://social.msdn.microsoft.com/forums/en-US/Vsexpressvc/thread/3d996f16-62bd-42e7-a15a-0ae3dc5dbf6b/

    *  "project creation failed error"
    http://blog.markarteaga.com/IE7AndVS2005.aspx

    * VS2008 - Getting "Creating project 'projectname'... project creation failed"
    http://blogs.msdn.com/rakkimk/archive/2009/02/24/vs2008-getting-creating-project-projectname-project-creation-failed.aspx

    * Can't Start New Smart Device Projects
    http://social.msdn.microsoft.com/forums/en-US/windowsmobiledev/thread/047e0a18-3aba-436d-b0b0-1e8b2cab2cce/

    After reinstalling the System; updating & patching it; installing VS and all the needed modules -I believe-, not to say that I'm frustrated, and that any help would be appreciated.


    • Moved by Figo Fei Friday, June 5, 2009 10:44 AM (From:Visual Studio Setup and Installation)
    Wednesday, June 3, 2009 11:05 AM

Answers

  • Hi Old Newbie,

    The VC++ Wizards Engine implements the IInternetSecurityManager interface.  In this implementation it allows or disallows specific actions under certain policies that Internet Explorer queries it about.  In IE8 a custom Security Manager now also gets queried about the URLACTION_ACTIVEX_OVERRIDE_REPURPOSEDETECTION policy which IE previously did not delegate to custom security managers when the engine wasn’t running in the iexplore.exe process.  The IE engine then fails this action because we don’t have a policy entry for it in the custom zone for VC++ Wizards. We are still investigating whether this change in IE8 is by design and will possibly be addressing it by a fix in either the Wizard or IE components depending on the outcome.



    Please follow the following steps:

    -          Open regedit (on a 64-bit OS, open the 32-bit regedit)

     

    -          Under “HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet
    Settings\Zones”, create a new key called 1000 (if it isn't already there)

     

    -          Under 1000, create a DWORD entry with:

    o   Name = 1207

    o   Type = REG_DWORD

    o   Data = 0x000000


    For more information:
    http://blogs.msdn.com/vcblog/archive/2009/03/28/some-vs2005-and-vs2008-wizards-pop-up-script-error.aspx


    Best regards,
    Guang-Ming Bian - MSFT
    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Monday, June 8, 2009 6:01 AM

All replies

  • Hi Old Newbie,

    The VC++ Wizards Engine implements the IInternetSecurityManager interface.  In this implementation it allows or disallows specific actions under certain policies that Internet Explorer queries it about.  In IE8 a custom Security Manager now also gets queried about the URLACTION_ACTIVEX_OVERRIDE_REPURPOSEDETECTION policy which IE previously did not delegate to custom security managers when the engine wasn’t running in the iexplore.exe process.  The IE engine then fails this action because we don’t have a policy entry for it in the custom zone for VC++ Wizards. We are still investigating whether this change in IE8 is by design and will possibly be addressing it by a fix in either the Wizard or IE components depending on the outcome.



    Please follow the following steps:

    -          Open regedit (on a 64-bit OS, open the 32-bit regedit)

     

    -          Under “HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet
    Settings\Zones”, create a new key called 1000 (if it isn't already there)

     

    -          Under 1000, create a DWORD entry with:

    o   Name = 1207

    o   Type = REG_DWORD

    o   Data = 0x000000


    For more information:
    http://blogs.msdn.com/vcblog/archive/2009/03/28/some-vs2005-and-vs2008-wizards-pop-up-script-error.aspx


    Best regards,
    Guang-Ming Bian - MSFT
    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Monday, June 8, 2009 6:01 AM
  • Thanks a lot.

    That works for me.

    Tuesday, June 9, 2009 6:24 AM
  • Thank you so much
    Friday, June 28, 2013 10:36 AM