none
Can not Save Application Manifest when adding https://onestore.microsoft.com to "identifierUris"

    Question

  • If you follow these steps in the documentation:

    Step1 Item 5

    https://docs.microsoft.com/en-us/windows/uwp/monetize/view-and-grant-products-from-a-service#step-1

    Add several required audience URIs to your application manifest In the left pane, click Manifest. Click Edit, replace the "identifierUris" section with the following text, and then click Save.

    You get the following error when saving the manifest:

    Error detail: The Application ID URI must be from a verified domain within your organization's directory.

    Either there's a bug in the manifest save or an issue with the documentation.  



    • Edited by Diego Link Friday, April 19, 2019 8:12 PM
    Friday, April 19, 2019 8:00 PM

All replies

  • Hi Diego,

    Sorry for the delay reply.Did you Add your custom domain name to Azure AD and Verify your custom domain name before configuring the application in Azure AD? You could check it with the step(Azure Active Directory> Custom domain names). I tested with the verified domain name and didn't encounter the error. 

    Best regards

    Daisy  Tian


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, April 23, 2019 6:31 AM
    Moderator
  • I do have a verified custom domain.  So should the identifier URLS in the manifest be replaced with the custom domain?

    Instead of :

    "https://onestore.microsoft.com/b2b/keys/create/collections"

    It's

    "https://<custom_domain>/b2b/keys/create/collections"

    ?

     If so the documentation is VERY poor:  It states:

    Click Edit, replace the "identifierUris" section with the following text, and then click Save.

    Nowhere does not state to replace the URLS with your custom domain.  

    Tuesday, April 23, 2019 4:57 PM
  • Hi Diego,

    Maybe it shouldn't be replaced with a custom domain.What did your App ID URI (AppName/Setting/Properties/App ID URI) contain? Could you mind to contain the <custom_domain>(like: https://<Custome_domain>/AppName) in your App ID URI to try again?

    Best regards

    Daisy  Tian


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, April 25, 2019 9:19 AM
    Moderator