locked
WCF DataService 4 Resource Not Found Exception RRS feed

  • Question

  • I'm finding WCF DataServices are trickier to setup than standard WCF services, for me at least.  So please forgive the newbie question.

    Ok, I have a WCF Service Project that I've added a WCF DataService to in order to expose my entities (.edmx and POCO files contained is separate projects).  Thanks the help of this forum yesterday/this morning, I was able to clear up an issue I had with certain dlls not getting published.  I am developing on a Windows XP with Visual Studio 2010 SP1 and am deploying the application to IIS on a Windows 7 machine.  If I run my project in the VS debugger I am able to browse my data through Chrome with no problems.  If I deploy to the Windows 7 machine I can browse the data no problem on that machine (the actual data from the database, not just the service metadata).  I can generate a service proxy in VS on my development machine by pointing the generation utility at the endpoint on the Windows 7 machine and I can browse the metadata in Chrome from my development machine.  But if I try to run an application using the generated service proxy or browse to any of the data using Chrome I get a 404 Resource Not Found Error.

    I have to imagine that this is a configuration error of some sort in IIS.  From browsing online I've manage to rule out what seem to be the solutions that others have found.  My site is running in Full Trust, my application pool is running under a domain account that has access to the directory structure of the application and the database the entities are connecting to, and the IIS authentication for the site is set to allow anonymous access through the Application Pools identity.

    I've also tried adding a webHttp binding to the service, but that did not seem to accomplish anything.  Do I need to setup any other endpoints to get this to work or should the default endpoint be enough?

    Thank you for your help and let me know what other information you might need to help me.

    Friday, July 6, 2012 7:15 PM

Answers

  • Well, I'm not sure how this worked, but I ran another test this afternoon and without having made any changes it just started working...  I guess I'll close this.
    • Marked as answer by lawso1dw Monday, July 9, 2012 7:02 PM
    Monday, July 9, 2012 7:01 PM