locked
"failed to connect to device as it is developer locked" after installing Mango RRS feed

  • Question

  • Hi,

    I just ran the update process and updated my Samsung Focus to Mango. When I try to deploy my applications from VS and Application Deployment, I receive the following error:
    "failed to connect to device as it is developer locked"

    Has anyone else got this? Has anyone found a resolution? Thanks.
    Thursday, June 30, 2011 4:24 AM

All replies

  • I get the same message. Haven't had time to troubleshoot yet.
    Thursday, June 30, 2011 4:37 AM
  • Isn't this just the normal "issue" where you screen needs to be one when you have to deploy an app to it?
    Try turn on your phone, so there is light in the screen and try again. Also make sure yoru phone is not locked with a pass code.

    Hope it helps.
    Thursday, June 30, 2011 7:06 AM
  • Hi William.

    I believe I read somewhere that upon updating to Mango your device might become re-locked as a regular device. (This happened to my Samsung Omnia 7 when I upgraded)
    Just go into the Windows Phone Development Tools -> Windows Phone Developer Registration and re-run the device registration. It should open your phone for development once more.
    Thursday, June 30, 2011 7:44 AM
  • Hi,

    solution is to unlock the device after the update: Use

    64-bit: C:\Program Files (x86)\Microsoft SDKs\Windows Phone\v7.1\Tools\Phone Registration
    32-bit: C:\Program Files\Microsoft SDKs\Windows Phone\v7.1\Tools\Phone Registration

    Reason: The phone gets locked during the update.

    Regards,
     -tobias
    Thursday, June 30, 2011 8:23 AM
  • I read elsewhere on these forums that you have to dev unlock your device again after the Mango update.  Could that be it?
    Thursday, June 30, 2011 9:13 AM
  • Yup, same happend to me. You just have to re-unlock.
    Thursday, June 30, 2011 10:37 AM
  • I'm having the same issue...

    I tried to re-unlock it, with no success. The tool reports back that it can not connect to the phone.

    I'm guessing that, as before "officially" unlocking it I used the Chevron tools - maybe those fake certificates are messing around. My next try will be to hard-reset the phone and start Mango "clean".

    Thanks!
    Thursday, June 30, 2011 12:57 PM
  • Yes, unlock the device using the tools. After that you can install apps.
    Worked for me.
    Thursday, June 30, 2011 1:48 PM
  • Yes, you must dev-unlock your phone the same way you did initially using the phone registration utility bundled with the SDK.
    Thursday, June 30, 2011 1:57 PM
  • I read elsewhere on these forums that you have to dev unlock your device again after the Mango update.  Could that be it?
    Yeah that fixes it perfectly.
    Thursday, June 30, 2011 2:35 PM
  • Yes, I was having the same problem, and using the "Windows Phone Developer Registration" tool to re-register my phone fixed the problem instantly.
    Thursday, June 30, 2011 4:02 PM
  • I'm really glad most of you could re-unlock your phones.

    Just before proceeding to a hard-reset, I tried again... no luck either. Yes, the phone is "screen unlocked" (the tool complains if the phone is not in that state before trying) and I have Zune open and connected. The error is the same: "Unable to connect to phone".

    Did any of you unlocked the phone first using Chevron tools and the unlocked it again with the "official" tool?

    Ok, let's start the reset... I'll post about the results.

    Thanks!
    Thursday, June 30, 2011 6:53 PM
  • Hard reset done (restored to factory settings)... and still unable to unlock the device.

    Fortunatelly, I discovered the issue (not fast enough :( )... The ChevronWP7 tool add bogus entries to the \Windows\System32\Drivers\etc\hosts file. So, if any of you have installed those tools, these are the steps to clean up before unlocking again:

    - Disconnect phone (to flush DNS cache recovered via DPTD connection)
    - Edit \Windows\System32\Drivers\etc\hosts
    - Remove all entries for "developerservices.windowsphone.com" (3 in my case).
    - Open a command prompt in administrator mode.
    - Execute IPCONFIG /FLUSHDNS
    - Connect phone and proceed to unlocking.

    Hope this helps any one with this issue.
    Thursday, June 30, 2011 7:35 PM

  • I can't Developer unlock my phone after Mango (7712) update either.

    I uninstalled Zune and Windows Phone SDK, then installed latest versions that came with the Mango Refresh.
    Updated to Mango 7712 OK.
    Setup Phone Sync Profile in Zune - all works fine.
    Deleted my phone registration details in App Hub Profile. (Waited over 15 minutes before retry).
    Never used ChevronWP7 but checked Hosts file anyway.

    But Windows Phone Developer Registration tool says "Unable to connect to phone. Please check that Zune software is running and that Zune's sync partnership with your phone has been established".

    I can't get any further. I've rebooted PC and phone many times but still cannot get Phone Registration Tool to see my phone.

    Please help!
    Thursday, July 28, 2011 8:23 PM
  • Hard Reset fixed it.
    Tuesday, August 9, 2011 10:59 PM
  • Hard reset done (restored to factory settings)... and still unable to unlock the device.

    Fortunatelly, I discovered the issue (not fast enough :( )... The ChevronWP7 tool add bogus entries to the \Windows\System32\Drivers\etc\hosts file. So, if any of you have installed those tools, these are the steps to clean up before unlocking again:

    - Disconnect phone (to flush DNS cache recovered via DPTD connection)
    - Edit \Windows\System32\Drivers\etc\hosts
    - Remove all entries for "developerservices.windowsphone.com" (3 in my case).
    - Open a command prompt in administrator mode.
    - Execute IPCONFIG /FLUSHDNS
    - Connect phone and proceed to unlocking.

    Hope this helps any one with this issue.

    Thank you so much!! I've done exactly what you said and it worked for me!
    Monday, August 29, 2011 8:23 PM
  • Me too. Thank you so much!
    Thursday, September 15, 2011 4:15 PM
  • This worked great. Thanks.
    Wednesday, September 28, 2011 7:37 PM
  • I had the same issue. I unregistred my phone and changed the phone name in Zune. After that I re-registred my phone with the Windows Phone Developer Registration tool. Now it works again.

    It's easier than a hard reset. ;-)
    Sunday, November 27, 2011 4:23 PM
  • I had the same issue. I unregistred my phone and changed the phone name in Zune. After that I re-registred my phone with the Windows Phone Developer Registration tool. Now it works again.

    It's easier than a hard reset. ;-)
    Dude, you are a Saint. I've never Chevron unlocked the phone before and It's worked fine since Mango, however recently it locked itself and simply wouldn't unlock. Thank you!
    Tuesday, November 29, 2011 5:15 PM
  • I still am unable to deploy my .xap package into my windows phone 7 device for testing.  This is what I have tried:
    1) Reset the phone using settings menu.
    2) setup the phone using my windows live id
    3) Run "windows phone developer registration" tool with the same windows live id to successfully register my phone.
    4) Then using "Application Deployment" tool, select my .xap package and select the Target Windows phone device.

    This gives me a "failed to connect to device as it is developer locked"

    What I haven't done is pay the $100 at App hub.  My User profile doesn't have have a devices section.  The question is do I need to pay the $100, then somehow get my device added into App hub, and then when I select deploy from application deployment tool, it will just work?
    Monday, December 12, 2011 11:48 PM
  • Had same issue. Simply unregistered and re-registered (didn't change name). Problem solved. Thanks.
    Wednesday, December 14, 2011 7:43 PM
  • Hi All,

    I have the same issue.
    I had unlocked my device and was using it and all of a sudden it gives me a message saying the device is developer locked.  I tried doing the registration and it gives me the message saying that your phone is successfully registered but when i try to deploy a application it gives me the old error. How should i over come this issue.

    I tried all the methods which are mentioned in this forum but none is working.

    Thanks in advance.

    Regards
    BIju

    Monday, December 19, 2011 4:52 AM
  • Hi All,

    I have the same issue.
    I had unlocked my device and was using it and all of a sudden it gives me a message saying the device is developer locked.  I tried doing the registration and it gives me the message saying that your phone is successfully registered but when i try to deploy a application it gives me the old error. How should i over come this issue.

    I tried all the methods which are mentioned in this forum but none is working.

    You are likely seeing an issue where your phone was unlocked about a year ago and it has hit the "unlock expiration date."  After unlocking/registering the device, use the same tool to relock/unregister the device and unlock it again.  The other option is to look in your user profile in the devices tab to see what the expiration date is listed as and remove it from the list and then unlock it again.

    The unlock-lock-unlock method was not mentioned in this thread, but it has been discussed in a few other threads in this forum. :)


    Monday, December 19, 2011 8:16 AM
  • Hi,

    Thanks for the response.
    I tried opening the APP Hub --> user profiles --> devices.
    it shows no device is registered. i tried register / un register / register but it effect remains the same.
    Please let us know is there any thing which i can do to make this mobile for development

    Thanks again
    Biju
    Tuesday, December 20, 2011 5:10 AM
  • Seeing the same issue on my account - tried everything listed in this thread with no success, and no devices are listed under my user profile.  My phone was previously unlocked before Mango.
    Tuesday, December 20, 2011 5:41 AM
  • Hi,

    Have you resolved this issue.
    We are still struggling with it.
    Let us know if you have found any solution for this.


    Regards
    Biju Melayil
    Thursday, December 29, 2011 1:57 AM
  • If the device was originally registered with a different account, it needs to be removed from the devices list of that account.

    See more details here:
    http://www.leventoz.com/Blog.aspx?BlogLink=http://leventoz.wordpress.com/2011/12/29/failed-to-connect-to-device-as-it-is-developer-locked/
    Friday, December 30, 2011 12:38 AM
  • I am having the same issue as well.

    I have Zune up, used the 7.1 registration tool, and the result said that it was "successful" but my phone is still locked!

    We should probably report this to MS and see if its a bug or not.
    Thursday, January 5, 2012 7:53 AM
  • **Edit: Mystery solved! Turns out I had registered my phone under a different dev account and forgot about it! Embarrassing! So I unregistered the phone on that account, and registered on my current account and everything is right in the world. Whew...
    Friday, January 6, 2012 5:18 AM
  • It looks like there are multiple causes for the error.  Here's another one:

    Situation: Credit card date expired, forgot to update info on billing.microsoft.com.
    Response: All developer apps on my phone were "Revoked by Microsoft".

    Situation: Updated credit card info on billing.microsoft.com.  Ran Visual Phone developer to reinstall the apps.  Visual Phone Developer complained that the phone was locked.  Try re-registering the phone with success, but VPD still complained the phone was locked

    Response: Removed the phone via create.msdn.com, re-registered phone.  Everything works now.
    Sunday, January 8, 2012 6:49 AM
  • THis worked for me - thanks.
    Friday, February 24, 2012 5:32 AM
  • Same for me!

    Credits for Skuami!!!
    Friday, March 23, 2012 2:57 PM
  • I had the same issue. I unregistred my phone and changed the phone name in Zune. After that I re-registred my phone with the Windows Phone Developer Registration tool. Now it works again.

    It's easier than a hard reset. ;-)



    Perfect! thanks!
    Saturday, April 28, 2012 6:21 PM