none
401 and then 304 RRS feed

  • Question

  • Hi,

    We are using windows authentication for one of our intranet applications (Built on .Net) and For example, when a page is getting loaded, consider that there 100 links which are getting referred to different images, css files etc... For each of these links, the request is going twice to IIS and for the first time IIS is throwing 401 status (Unauthorized exception) and next it's throwing 304 (reading it from cache) status because of which the images are getting displayed. This is hitting performance of our application and we need to fix this.

    We have tried the following configuration changes but they did not work for us in fixing this issue.

    • Checked the “Http Keep-Alives” property of Default Web site and kept it to True.
    • Checked if multiple authentication methods are enabled (Checked Web.Config, Default Website’s config and website’s property).
    • Used the Metabase Explorer and set the  AnonymousPasswordSync to true, We can do it from Command prompt also: inside c:\inetpub\wwroot use this command: adsutil.vbs set W3svc/AnonymousPasswordSync 1
    • Creating a new web.config file inside images folder and set authentication mode =”none” but still its showing 401 exceptions.
    • Giving full access to the user who is accessing the application but still it showed 401 exceptions.
    •  ** iisreset and cache clearance has been done after every change.

    Can some one quickly help us in this case??

    Many thanks !!

    Friday, May 18, 2012 11:24 AM

All replies

  • Hi,

    you should check IIS or ASP related forum places for this specific issue.
    This forum is for WPT questions only.

    Best regards.


    RPA

    Friday, May 18, 2012 8:50 PM