none
IoT Edge - dependency on missing ssl libraries on ubuntu RRS feed

  • Question

  • systemctl start iotedge fails on ubuntu 18.04.02:

    .../iotedged: error while loading shared libraries: libssl.so.1.0.2: cannot open shared object file

    .../iotedged: error while loading shared libraries: libcrypto.so.1.0.2: cannot open shared object file

    The iotedge application is linked against openssl 1.0.2

    canonical has backported 1.0.2 fixes to 1.0.0, so the installed version is:

    libssl1.0.0:armhf               1.0.2n-1ubuntu5.3

    Resolved by creating appropriate symlinks:

    cd /usr/lib/arm-linux-gnueabihf/

    ln -s libcrypto.so.1.0.0 libcrypto.so.1.0.2

    ln -s libssl.so.1.0.0 libssl.so.1.0.2

    Tuesday, May 7, 2019 10:09 PM

All replies