none
JAVA_HOME: The system cannot find the path specified.

    Question

  • Dear All,

    I installed Github  recently and in hadoop command line I get following error

    I ran into this problem couple of days ago and still not finding the way to resolve it.

    Whenever I open the Hadoop command line, I get JAVA_HOME not set error as shown below

    The system cannot find the path specified.
    Error: JAVA_HOME is incorrectly set.
           Please update c:\Hadoop\hadoop-1.1.0-SNAPSHOT\conf\hadoop-env.cmd
    Usage: hadoop [--config confdir] COMMAND

    Few options I tried

    1.Changed the Java_Home path to  C:\Hadoop\java\bin in my system

    Also changed in C:\Hadoop\hadoop-1.1.0-SNAPSHOT\conf\hadoop-env.sh as export JAVA_HOME="C:\Hadoop\java\bin"

    But this did not solve the problem

    2.I had local installation of Java.So I thought it could be the problem. I also tried pointing JAVA_HOME in both my system environment variables and in script as

     export JAVA_HOME="C:\Program Files\Java\jdk1.7.0_40"

    But again this problem has not solved

    Am I missing out something here?

    Did anyone face similar problem? If yes what is the solution.


    Also note: entering java or javac in hadoop command line lists all the commands but none of the hadoop commands work
    • Edited by HadoopUser Tuesday, December 10, 2013 12:02 AM addition of note
    Monday, December 09, 2013 11:31 PM

Answers

All replies

  • Hi,

    I think you may need some tutorails as reference.Please Bing this issue.

    Tuesday, December 10, 2013 2:56 PM
  • Thank you.The problem is resolved.I removed Emulator and reinstalled all over again...somehow its working without any error message!!
    Thursday, December 12, 2013 12:45 PM
  • I have just made the same problem, would you like to give me more detail a bout it as well as how to fix it. Thanks
    Sunday, April 27, 2014 4:29 PM
  • Hi,

    Am facing the same error JAV_HOME not set properly. you said that i removed Emulator and reinstalled all over again, 

    What is Emulator where it exists and how to remove please let me know how to resolve above error

    Thanks,

    Sudhakar.

    Thursday, March 19, 2015 5:59 AM
  • I too would like to know what you mean by "removed Emulator."  Also getting this problem, and cannot find any solutions online so far.
    Tuesday, May 05, 2015 8:51 PM