none
Incorrect .Net framework version is being displayed on server error page. RRS feed

  • Question

  • I have IIS 8.5 and .Net Framework version 4.7.2 installed in my machine. 
    My web application target framework is set to 4.7.2 in Visual Studio.  
    However, I have notice that when I get an application run time exception, the version information displayed at the bottom of the yellow server page says .Net Framework Version: 4.0.30319; Please may I know why it is not showing ver4.7.2.



    • Edited by Rav Bob Tuesday, June 11, 2019 7:24 PM
    Tuesday, June 11, 2019 2:53 PM

All replies

  • Hi Rav Bob,

    Thank you for posting here.

    For the .NET Framework versions 4, 4.5, 4.5.1, and 4.5.2, the string representation of the returned Version object has the form 4.0.30319.xxxxx, where xxxxx is less than 42000. For the .NET Framework 4.6 and later versions, it has the form 4.0.30319.42000.

    For more details, please refer to the link below.

    https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/how-to-determine-which-versions-are-installed

    Best Regards,

    Wendy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, June 12, 2019 2:41 AM
    Moderator