locked
Error While Communicating with the WCF HTTP service RRS feed

  • Question

  • Hi,

    I have configured solicite request-responce send port with WCF-Custom adapter for communicationg the HTTP Service using binding file(generated while Consuming service using BT Wizard)

    Every time I tryed to communicate with service It`s giving me below error.

    Can anyone suggest me about cofiguration for same?


    Praj Dixit


    • Edited by PrajaktD Wednesday, September 9, 2015 9:27 AM
    Wednesday, September 9, 2015 9:23 AM

Answers

  • Hi

    Since it is a WCF-CUSTOM adapter, in the configuration what is the BindingType?

    Check the following:

    1. Is the URI https or http, if it is https and the binding type is webHttpBinding or BasicHttpBinding or WsHttpBinding, then select the Security WebHttpBindingElement and set the Mode to Transport. If it is http then Security may not be required.

    2. If the it is HTTPS endpoint certificate must be registerd in the certificate store at Trusted root to avoid any issues

    Regards

    K

    • Proposed as answer by Angie Xu Thursday, September 17, 2015 2:52 AM
    • Marked as answer by Angie Xu Monday, September 21, 2015 1:48 AM
    Wednesday, September 9, 2015 9:33 AM

All replies

  • Hi

    Since it is a WCF-CUSTOM adapter, in the configuration what is the BindingType?

    Check the following:

    1. Is the URI https or http, if it is https and the binding type is webHttpBinding or BasicHttpBinding or WsHttpBinding, then select the Security WebHttpBindingElement and set the Mode to Transport. If it is http then Security may not be required.

    2. If the it is HTTPS endpoint certificate must be registerd in the certificate store at Trusted root to avoid any issues

    Regards

    K

    • Proposed as answer by Angie Xu Thursday, September 17, 2015 2:52 AM
    • Marked as answer by Angie Xu Monday, September 21, 2015 1:48 AM
    Wednesday, September 9, 2015 9:33 AM
  • Hi Praj,

    Did you assign the certificate to the port?

    For this issue, This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS case. I think you should check your port whether blocked or bind the certificate correctly.

    Please verify any certificate configured on port, Please follow below steps to configure certificate in BizTalk,

    How to configure SSL Certificate for BizTalk HTTP send port adapter (part 1)

    How to configure SSL Certificate for BizTalk HTTP send port adapter (part 2)


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    Wednesday, September 9, 2015 9:44 AM
    Moderator
  • Hi,

    You are getting the below exception:

    basically the authentication is failing and remote host is rejecting the connection. Check what all security protocol (TLS, SSL) is supported by the remote host for connection.

    Please look into the below post that was having the same issue:

    TLS 1.0 and SSL3 woes in your BizTalk WCF send port

    Please indicate "Mark as Answer" or "Mark as Helpful" if this post has answered the question

    Rahul

    Wednesday, September 9, 2015 9:50 AM