locked
Get an Error 3001 in MS Access 2013 when attaching MS Word Document to SharePoint linked List RRS feed

  • Question

  • Hi there.

    Hopefully there is some-one who has came across this scenario.

    I have an Access 2013 Desktop application with tables linked to SharePoint 2013 onPrem Lists.

    The app reads data from the linked SharePoint lists and I generate an MS Word document, which I save to the user's local My documents folder, after which I terminate the MS Word objects and close MS Word.

    Then I use the DAO model to open one of the tables (linked to SharePoint) to attach the newly created MS Word .docx file as an attachment to the relevant entry in the table/list.

    All works fine, but as as soon as the docx file is larger than 2.5 MB in size, I get an error 3001 on the update attachment instruction. If I attach smaller files, it works fine and no error occurs. So this scenario is stuffing me around for a few days now, and I managed to determine the following:

    1. I don't think it is an issue on the SharePoint side, because I can attach a 50MB file to entry in the same List when using the SharePoint form in IE 11.This means that there is not an issue on the SharePoint side, as far as I can tell.
    2. I run the same app on a Remote Desktop which is located in the the same Data Center and has a 1GB/s network connection to the SharePoint environment, and then this error doesn't occur. Therefore the problem is not code related.
    3. If I open the table entry in an Access form, and I attach a small file (2.2MB) to the entry via the form UI, the attachment succeeds without an error. As soon as I attach a larger file (3.3MB) an error occurs: "Linked Table is unavailable. Microsoft Access cannot contact the server. Check your network connection or contact the server administrator." If I then attach the smaller file of 2.2MB thereafter, it succeeds without any issue. The message is not correct because there is no problem with the connection to the SharePoint server.
    4. I began to suspect it has something to do with a timeout of some sort. I started to time the attachment operation. As soon as it exceeds 60 seconds an error occur. The smaller files saves quicker then 60 seconds therefore it is saves successfully. The only timeout related setting I can find in Access Options, is under Client Settings, OLE/DDE Timeout (sec) which I increased from 60 seconds to 600 but the same error occur. I also change the timeout value in the Application.CurrentDb.QueryTimeout from 60 to 600 seconds, but the 3001 error still thrown when attaching a larger file.

    Hopefully, some-one else has had a similar battle to find a solution to this issues or can assist me in tracking down the issue, and resolving it.

    I am looking forward to hear from you...

    Monday, September 14, 2015 4:52 PM

All replies

  • Hi RS4_Roar,

    I made a test with your description, but I failed to reproduce your issue. From Access 2013 desktop application, I test with 6.9MB file, and it upload correctly.

    I think your assume is right, it might be caused by timeout. I made a research about this error, and found a helpful link. Hotfix (KB 2552989) which will allow the timeout behavior to be a configurable value. KB 2553007 provides the steps on creating the necessary registry key to specify the new timeout value.

    #Access: Troubleshooting errors opening linked SharePoint lists/document libraries
    https://support.microsoft.com/en-us/kb/2702762

    Hope it will help.

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Tuesday, September 15, 2015 7:06 AM
  • Thank you very much for your response Edward.
    I read through the links you provided, but they all refer to MS Access 2007 and 2010.

    I am just worried that if I apply the fix to my Access 2013 it may cause issues with 2013 version. The hot fix only apply to Office 2010 which I don't have installed on my computer.

    Do you perhaps know how to change this "timeout" value in for the Office 2013 version?

    Tuesday, September 15, 2015 8:13 AM
  • That's some fine sleuthing right there...  I don't have a suggestion, but I hope you get this sorted.
    • Edited by Gary Voth Tuesday, September 15, 2015 1:06 PM
    Tuesday, September 15, 2015 1:05 PM
  • That's some fine sleuthing right there...  I don't have a suggestion, but I hope you get this sorted.

    Indeed Gary, its a battle to find a solution for this one...
    Tuesday, September 15, 2015 2:33 PM
  • Hi RS4_Roar,

    >> I am just worried that if I apply the fix to my Access 2013 it may cause issues with 2013 version. The hot fix only apply to Office 2010 which I don't have installed on my computer.

    To be honesty, I could not reproduce your issue, I did not have such an environment to test. I suggest you test this in your virtual machine.

    >> Do you perhaps know how to change this "timeout" value in for the Office 2013 version?

    What I have known is to set OLE/DDE timeout (sec), I suggest you set the value with 300 instead of 600. Valid values for OLE/DDE timeout (sec): is 0-300.
    # Customize advanced options for your application
    https://support.office.com/en-us/article/Customize-default-settings-for-your-databases-50077bf5-ffaa-4215-9a73-5b8b81ea057d

    I suggest you test your issue under a high bandwidth connection.

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Wednesday, September 16, 2015 6:46 AM
  • What I have known is to set OLE/DDE timeout (sec), I suggest you set the value with 300 instead of 600. Valid values for OLE/DDE timeout (sec): is 0-300.
    # Customize advanced options for your application

    I suggest you test your issue under a high bandwidth connection.

    Thanks Edward, I tried this with many combinations of values, but no success yet.

    Even tried changing the DAO QueryTimeout property without success...

    Thursday, September 17, 2015 7:47 AM
  • The Error number and Description is totally misleading:

    Error No: 3001 - Invalid argument. Has nothing to do with a timeout or file size.

    Thursday, September 17, 2015 8:59 AM
  • Hi RS4_Roar,

    Due to I could not reproduce your issue, I suggest you compact and repair database to check whether it would work.

    If it did not work, I suggest you update your Access to latest version.

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Friday, September 18, 2015 9:10 AM