locked
Deploy silverlight application - not working RRS feed

  • Question

  • Hi every one,

    I'm trying to deploy my silverligth application on a server via https.

    I've installed Ria Service Toolkit, but I cant' install Ria Services V1.0 because it requires Visual Studio Developer 2010.

    I can't find Visual Studio Developer 2010 alone, but all the Visual Studio Express.

    I think it's wrong install the developer enviroment on a machine where my application has to be deploy...

    In this moment when my silverlight application try to do query (like the typical GETUSER) I get the 404 Not Found exception on "Load Operation Failed".

    Any ideas??

    What should I do / install???

    Thank you very very very much!!!!!!

    Monday, February 11, 2013 2:38 PM

Answers

All replies

  • Installing RIA Services on the server is not recommended anymore, the documentation is out of date. if you add the RiaServices.Server NuGet package to your web application the needed dlls will be marked as copy local and will be in the bin folder to be copied to the server.

    You can also just mark the dlls as copy local in your existing solution as-is without the NuGet package, but the NuGet package is safer because an old RIA Services installation on a server will not override it.


    http://www.riaservicesblog.net | RIA Services and MVVM http://bit.ly/pgL97k

    Monday, February 11, 2013 6:42 PM
  • Hi Colin and thanks for your answer.

    I've added RiaServices.Server NuGet package to my web project, and now i have two more dll in the bin folder ( System.ServiceModel.DomainServices.Hosting and System.ServiceModel.DomainServices.Server).

    I've copied my xap and the bin folder on my server but nothing has changed.. always the "Load operation failed" message.

     

    Any ideas?

    thanks again!!!

    Tuesday, February 12, 2013 8:35 AM
  • Colin, I want to deploy in https. Does it changes something?

    Tuesday, February 12, 2013 8:55 AM
  • Have you used Fiddler to check your .svc file is working?
    Tuesday, February 12, 2013 9:21 AM
  • Hi Aly,

    with Firebug for Firefox I've seen the 404 Error Not Found.

    I've tried browsing my domain service .svc (in this way http://myhost/MyApplication-Web-CustomerDomainService.svc), but it failed (error 404). In localhost, i can browse it wihout problems.

    Thank you!


    • Edited by FedericaDR Tuesday, February 12, 2013 9:35 AM
    Tuesday, February 12, 2013 9:34 AM
  • There's a post over here that may be similar to what you're doing, does it help?
    Tuesday, February 12, 2013 11:31 AM
  • I don't know how it could help me.. because it speaks about services and not the general app configuration (or iis config)

    Tuesday, February 12, 2013 12:45 PM
  • The main troubleshooting guide can be found at http://msdn.microsoft.com/en-us/library/ff426913(v=VS.91).aspx and you should review that if you haven't already.

    One thing not in the troubleshooting guide that you may find useful is to create an explicit svc file. Create an svc file in your web folder and for the contents enter

    <%@ ServiceHost Service="Your.Domain.Service"
        Factory="System.ServiceModel.DomainServices.Hosting.DomainServiceHostFactory" %>
     
    

    If you still have problems, it would be helpful to know what kind of DomainService and DAL you are using.

    http://www.riaservicesblog.net | RIA Services and MVVM http://bit.ly/pgL97k

    Tuesday, February 12, 2013 3:36 PM
  • Thank you all for the useful links, but I think I've solved my problems!

    I've succeeded in installing Ria Services without any Visual Studio tool installed.

    The solution is here: http://timheuer.com/blog/archive/2009/12/10/tips-to-deploy-ria-services-troubleshoot.aspx

    Thank you very much!!!

    • Marked as answer by FedericaDR Wednesday, February 13, 2013 7:57 AM
    Wednesday, February 13, 2013 7:57 AM