locked
Dax Cubevalue RRS feed

  • Question

  • So I have an issue with cubevalue behaving consistently from a DAX expression in my tabular SSAS cube.  The measure is:

    RunningTotalLCYPeriodStart:=CALCULATE([Amount], FILTER( ALL('PostingDate'[FinancePeriodStartDate]),'PostingDate'[FinancePeriodStartDate] <= MAX('PostingDate'[FinancePeriodStartDate])))

    Using a pivot to connect to the model I have no issues and the data is displayed correctly.  When I convert this pivot to OLAP formula's or I try to manually create cubevalue formulas it either provides me with the value for only that filter data (in my case Period and Year) or it does under other circumstances provide me with correct values e.g. (ignore total in bold as I havent included all the rows that make this up).

    Anyone had similar issues?

    Pivot results

    Row Labels Amount RunningTotalLCYPeriodStart
    Accruals -277,369 -277,369
    12/31/2017 188,745 188,745
    1/28/2018 -399,094 -210,349
    2/25/2018 378,842 168,493

    Cubevalue results:

    Row Labels Amount RunningTotalLCYPeriodStart
    Accruals -277368.9 -277368.9
    12/31/2017 188745.21 188745.21
    1/28/2018 -399094.21 -399094.21
    2/25/2018 378841.84 378841.84


    mbutlin

    Tuesday, November 27, 2018 1:43 PM

All replies

  • MButlin, have you made any progress on this issue?

    Thanks!


    Ed Price, Azure Development Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Friday, April 5, 2019 2:36 PM
  • Hi No unfortunately not still a problem which I haven’t managed to resolve. My feeling is that it is somewhere in Excel as the pivot wouldn’t return the correct values without that. I have a support call open but that hasn’t made any progress. Matthew

    mbutlin

    Friday, April 5, 2019 6:54 PM
  • So this is an issue with the Excel product that MS will work on fixing, no dates yet.

    mbutlin

    Wednesday, April 17, 2019 12:30 PM