none
Breakpoints not working when debugging SharePoint workflows RRS feed

  • Question

  • Hi All

    Is it possible to add Breakpoints when debugging SharePoint Online Workflows in Visual Studio 2015? I can debug the Workflows using Azure Service Bus ok, but if I add breakpoints they are never hit and paused. I would like to add breakpoints so the workflows pauses and I can get properties from the Watch Window.

    Can someone tell me how to get Breakpoints working when debugging SharePoint Online workflows? Maybe debugging Workflows using Breakpoints is not possible from SharePoint Online.

    I Hope you can help
    Colin



    • Edited by ceBlueSky Saturday, March 4, 2017 4:21 PM
    Thursday, March 2, 2017 2:31 PM

Answers

  • HALLELUIAH !!!  I found the solution. I needed to untick:
      “Options > Debugging > General > Enable Just My Code”

    • Marked as answer by ceBlueSky Saturday, March 4, 2017 4:21 PM
    Saturday, March 4, 2017 4:21 PM

All replies

  • Hi ceBlueSky,

    It's available to debug SharePoint Online workflow using Visual Studio, please check the article below for more detailed steps:

    Debugging Workflows In SharePoint 2013 Online using Azure

    Thanks

    Best Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Proposed as answer by Sjoukje ZaalMVP Friday, March 3, 2017 8:07 AM
    • Unproposed as answer by ceBlueSky Friday, March 3, 2017 1:16 PM
    Friday, March 3, 2017 6:14 AM
  • I've done everything as described in your link. The Workflow works OK and the Azure Service Bus command line appears, but no breakpoints are hit.

    I either press F5 or I  go to Debugging > Start Debugging. It still goes past all the break points without stopping.

    PLEASE SOMEONE ONE ON THIS BLUE PLANET HELP ME !!!

    :-(



    • Edited by ceBlueSky Friday, March 3, 2017 1:21 PM
    Friday, March 3, 2017 1:16 PM
  • HALLELUIAH !!!  I found the solution. I needed to untick:
      “Options > Debugging > General > Enable Just My Code”

    • Marked as answer by ceBlueSky Saturday, March 4, 2017 4:21 PM
    Saturday, March 4, 2017 4:21 PM