locked
Upgrade from site asp.net 2.0 on iis 5 to asp .net4 ii8 RRS feed

  • Question

  • User-888770435 posted

    Hi,

    I want to move my site to a new server with windows server 2012 IIS 8 asp .net 4, from server with

    windows server 2003 IIS  6 ASP .NET 2.0

    I try to move has it is , but recieved error on web.config file

    What should I install on the new server, my site also usese Ajax Tools

    Thursday, July 10, 2014 3:33 AM

Answers

  • User-888770435 posted

    I manage to solve the problem.

    I define new web.config that fit to asp.net 4 , and after that add the spcial object to fit my site,

    I add more property to IIS application through - Add/updtae  Role /

    Thanks all for your answers.

    Liora 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, July 13, 2014 3:09 AM

All replies

  • User753101303 posted

    Hi,

    It would be best to tell which error you have. Don"t you think so ?

    Thursday, July 10, 2014 3:59 AM
  • User-888770435 posted

    This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
    Config File    \\?\C:\inetpub\wwwroot\NewSite\NewSite\web.config
    Thursday, July 10, 2014 4:39 AM
  • User753101303 posted

    The message doesn't tell which section it is ? See http://www.iis.net/learn/get-started/planning-your-iis-architecture/deep-dive-into-iis-configuration-with-iis-7-and-iis-8#Locking (in short, the config is hierarchical and a section could be "locked" at a higher level so that it can't be overriden at a web site level).

    I wonder if it couldn't also happen if you forgot to define your web site root as an IIS application or if files are misplaced (ie then the config system wouldn't realize that you are at the site level where you are allowed to do that but would think you are at a folder level where you are not allowed to use this setting). In particular I noticed your web.config seems to be in a NewSite folder which is already himself inside another NewSite folder. Is this expected ?

    Double check that the error message doesn't give any clue about which setting exactly triggers this error.

    Thursday, July 10, 2014 4:49 AM
  • User-888770435 posted

    Here are some more details:

    -------------------------------------------

    I define the root of the site:

    The Physicals path of my site:

    C:\inetpub\wwwroot\NewSite\NewSite

    web.config file - exist at this folder

    Pass-through- contact as : "Application user "

    Identify of the pool : "NetworkService"

    .net of the pool : "v4"

    The error :

    <fieldset>

    Detailed Error Information:

    Module    IIS Web Core
    Notification    BeginRequest
    Handler    Not yet determined
    Error Code    0x80070021
    Config Error    This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
    Config File    \\?\C:\inetpub\wwwroot\NewSite\NewSite\web.config
    Requested URL    http://localhost:80/
    Physical Path    C:\inetpub\wwwroot\NewSite\NewSite
    Logon Method    Not yet determined
    Logon User    Not yet determined
    </fieldset>
    <fieldset>

    Config Source:

       76: 		</modules>
       77: 		<handlers>
       78: 			<remove name="WebServiceHandlerFactory-ISAPI-2.0"/>
    
    </fieldset>

    Thursday, July 10, 2014 7:04 AM
  • User-888770435 posted

    I manage to solve the problem.

    I define new web.config that fit to asp.net 4 , and after that add the spcial object to fit my site,

    I add more property to IIS application through - Add/updtae  Role /

    Thanks all for your answers.

    Liora 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, July 13, 2014 3:09 AM