none
There was a failure executing the response(receive) pipeline...Finding the document specification by message type http://schemas.microsoft.com/crm/2007/BizTalkAdapter/YYY/Response#Response failed RRS feed

  • Question

  • We use the BizTalk Adapter for CRM 4.0 with BizTalk 2009 and we are getting the error below on a specific environment.
    Any idea why? Or where the adapter gets the schema from? As I can't see it under All Artifacts/Schemas, so I guess the CRM adapter uses it internally or something.

    There was a failure executing the response(receive) pipeline: "Microsoft.BizTalk.DefaultPipelines.XMLReceive, Microsoft.BizTalk.DefaultPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Source: "XML disassembler" Send Port: "CRMPort" URI: "http://XXX" Reason: Finding the document specification by message type "http://schemas.microsoft.com/crm/2007/BizTalkAdapter/YYY/Response#Response" failed. Verify the schema deployed properly.

    Where XXX was the IP and YYY was the CRM organization.

    Thanks
    Friday, February 26, 2010 9:57 AM

Answers

  • Hi,

    There are a couple of things you need to do, when you run into this type of error ( Finding the document specification by message type yourschemanamespace#root failed. Verify the schema deployed properly.' in your case:

    - Alok suggestion(s);
    - redeploy the assemblies (schema's) you are using;
    - make sure you are restarting all the hosts.

    Regards,

    Steef-Jan Wiggers
    MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


    BizTalk Server
    Friday, February 26, 2010 10:58 AM
    Moderator

All replies

  • Hi,


    Please check whether you have deployed the biztalk application containing the generated schemas from visual studio using add adapter metadata schemas option for crm 4.0.
    if yes  check whether the organization name which was provided while generating the schemas in visual studio  is the same as you are providing in the request response port.


    Thanks
    Alok MCTS(Biztalk) Please set answered or vote helpful if the post answered the question
    Friday, February 26, 2010 10:16 AM
  • Hi,

    There are a couple of things you need to do, when you run into this type of error ( Finding the document specification by message type yourschemanamespace#root failed. Verify the schema deployed properly.' in your case:

    - Alok suggestion(s);
    - redeploy the assemblies (schema's) you are using;
    - make sure you are restarting all the hosts.

    Regards,

    Steef-Jan Wiggers
    MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


    BizTalk Server
    Friday, February 26, 2010 10:58 AM
    Moderator