locked
SQL Server Error 258 RRS feed

  • Question

  • Hi Everyone,

    Please check the below screenshot once, One of my client getting this error he was unable to connect to the server.

    As I checked TCPIP protocol was enabled and i'm able to access the server as well but the guy getting below error message.

    Please suggest me how to troubleshoot this issue..Thanks in advance!

    Regards

    V


    DBA

    Tuesday, March 22, 2016 1:23 PM

Answers

All replies

  • I will surmise that the problem is specific to the one person, otherwise users would be complaining.

    My first thought is to check is connectivity, make sure he is on a network that can actually reach the SQL server.  At the risk of sounding like a network guy, can he ping the server?  Can he at least make an RDP connection to the point of being prompted for credentials? (Successful logon is a moot point as long as he is prompted).

    There is always the standard Windows question of how long has it been since the affected client machine (not the SQL server) has been rebooted, if it has been a while reboot.

    ---------------------------------------------

    Peter

    Tuesday, March 22, 2016 1:50 PM
  • Tuesday, March 22, 2016 2:56 PM
  • Windows authentication or SQL authentication?

    The message as such is the standard message when the instance cannot be reached. However, error 258 is unusual in this context. And it is not an SQL Server error, it's an OS error; NET HELPMSG 258 says The wait operation timed out.

    This could possibly indicate that you are arriving somewhere, but no one is actually listening. That is, the port is open but the process is busy with something else. (And that is necessarily not an SQL Server process.)

    Try connecting by IP-address and port number in case there is some DNS problem.

    Tuesday, March 22, 2016 10:08 PM
  •     select * from sys.messages
        where message_id = 258 and language_id = 1033

    Cannot call methods on %ls.

    Tuesday, March 22, 2016 10:17 PM
  • Hi There,

    make sure below check list is passed.

    1) ping the server from your client machine. (this will make sure network connection is ok)

    2) tcp/ip is enables

    3) if you are using different port make sure your client is including that number in the connection string

    4) finally on your SQL server make sure remote connection are allowed.

    All the best.

    Kumar

    Tuesday, March 22, 2016 11:52 PM
  •     select * from sys.messages
        where message_id = 258 and language_id = 1033


    Cannot call methods on %ls.

    Enric, 258 is an OS error message. You can't get an error message from SQL Server if you cannot connect to it. :-)

    Wednesday, March 23, 2016 10:12 PM
  • what clever am I, sorry, this error is previous to SQL

    Thanks

    Wednesday, March 23, 2016 11:10 PM
  • Thanks for your reply guys!

    DBA

    Monday, April 25, 2016 1:06 PM
  • Oddly, I see this happening more often than I'd expect.  I did notice that a PING to the server name came back with the IPv6 address rather than the IPv4 address.   I don't expect that would be the case with everyone, but I have the Windows 2016 Business Essentials setup as my domain controller and it may have been upgraded from previous versions.  I am still getting accustomed to differences.

    That said, at this point, there is a continuous Error 258 returned.   I tried changing the hosts file to reflect the IPv4 rather than the IPv6 (which worked), but the timeout still occurs.   I suspect there is an issue with certificates that may be beyond my ability to understand at this point.   I will persist here and discover some other method.

    Thus far  tried:

    <servername>\<instance>

    <servername>,<port>

    <servername>,<port>\<instance>

    The SQL Browser is running meaning the first one should have worked since it is all within the domain.  In the calling application D:\Program Files\Microsoft SQL Server\MSSQL14.HALLORAN\MSSQL\Binn\sqlservr.exe is a firewall exception and in the destination server, the port is open in the inbound rules.

    I am thinking the remote timeout being too short is nonsense - Ping is 3ms - but I'll try that too.

    Different than what the others have here - my database engine service is running on a group Managed Service Account that has domain and SPN capability across three servers running SQL Server Enterprise or Developer - whichever is preferred.   The SPN's will need to be checked.  Possibly that is also the issue.  One of the SPN requirements is to create the SPN only from the server itself (and I keep saying server but these instances are actually running on Windows 10 v1809 machines).

    So much to check now.  What happened to those good old days?  When life was so much easier.


    R, J

    Monday, January 21, 2019 8:16 PM
  • THE INTERNET!!!
    Monday, January 21, 2019 8:40 PM