none
Setting up IIS 10 for ASMX service

    Question

  • Hello

    I'm not sure this is the right forum, but finding the right one isn't always easy.

    I have 2 webservices of asmx-type developed for some years ago.

    The customer has been using them on a Windows Server 2008 with IIS 8, but are now upgrading to Windows Server 2016 with IIS 10.
    I have big problems getting the services to work or even start in this environment.
    I have installed .NET Framework 3.5 and ASP.NET 3.5 on the server but something is wrong anyway.
    If I enable directory browsing on the site, I can see the files, for example webservice.asmx, but when I click it in the browser I get a error 404 and message that the file was not found.
    I have tried comparing configuration from the old server, but it looks the same for every setting I have explored.

    I'm beginning to think that the asmx-type of webservice and IIS is not compatible.

    Does anyone have any input in this?


    Best Regards Peter Karlström Midrange AB, Sweden

    Wednesday, May 15, 2019 3:30 PM

Answers

  • Hi Peter Karlström,

    Welcome to the MSDN forum.

    Based on your description, it is not VS IDE issue indeed, but we find the “right” forum for you. Please redirect to IIS forum and start a new case to ask your question, you could get more professional support.

    Thank you for your understanding

    Sincerely

    May


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, May 16, 2019 9:01 AM
    Moderator

All replies

  • Hi Peter Karlström,

    Welcome to the MSDN forum.

    Based on your description, it is not VS IDE issue indeed, but we find the “right” forum for you. Please redirect to IIS forum and start a new case to ask your question, you could get more professional support.

    Thank you for your understanding

    Sincerely

    May


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, May 16, 2019 9:01 AM
    Moderator
  • Hello May

    Thanks for your reply and your tip. I will go there an post my question.

    Finding the right forum is very hard even when you know what you are looking for.
    You redirect me to IIS Forum, but I get no hits when I search for this forum from my logged in location (https://social.msdn.microsoft.com/Forums/en-US/home)


    Best Regards Peter Karlström Midrange AB, Sweden

    Thursday, May 16, 2019 10:24 AM
  • Hi Peter

    IIS forumhttps://forums.iis.net/

    Can you not to hit it successfully? Or cannot navigate to this site?

    May


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, May 17, 2019 6:56 AM
    Moderator
  • Hi May

    Sorry, I maybe explained my issue poorly.
    When I was trying to find the correct forum, I was logged in to https://social.msdn.microsoft.com/Forums/en-US/home.

    If you go there and try searching for the IIS Forum, you get no hits.

    Since both these sites are Microsoft sites, one might imagine that the forum should be found.

    I have no problem get to the IIS Forum using your link.
    I have posted my question there.

    Again, thanks


    Best Regards Peter Karlström Midrange AB, Sweden

    Friday, May 17, 2019 7:28 AM
  • Hi Peter,

    fine, i got it. if you encounter any VS IDE issue in the future, we will be glad to discuss it with you. :)

    have a wonderful day !

    May


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, May 17, 2019 8:37 AM
    Moderator