locked
Unable to activate windows tailored application RRS feed

  • Question

  • Hi,

    I have a C# project in Windows 8 Visual Studio 11 (Metr-Style) and try to run it today, I get the following error:

    Unable to activate windows tailored application


    I didn't have any Problems with this Project until yesterday. I have the same problem with new projects. If I create a new project, I have the following error (directly after the project opens.):

    System.Runtime.InteropServices.COMException
    Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))
    
    Server stack trace: 
       at Microsoft.Expression.DesignHost.Isolation.Remoting.ThreadMarshaler.CallQueue.WaitForCompletion(BlockingCall call)
       at Microsoft.Expression.DesignHost.Isolation.Remoting.ThreadMarshaler.CallQueue.Invoke(BlockingCall call)
       at Microsoft.Expression.DesignHost.Isolation.Remoting.ThreadMarshaler.MarshalIn(IRemoteObject targetObject, Action action)
       at Microsoft.Expression.DesignHost.Isolation.Remoting.RemoteDesignerView.Microsoft.Expression.DesignHost.Isolation.Remoting.IRemoteDesignerView.get_Element()
       at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
       at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
    
    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at Microsoft.Expression.DesignHost.Isolation.Remoting.IRemoteDesignerView.get_Element()
       at Microsoft.Expression.DesignHost.Isolation.Remoting.LocalDesignerView.Microsoft.Expression.DesignHost.IDesignerView.get_Element()
       at Microsoft.Expression.DesignHost.IsolatedDesignerService.CreateDesignerViewInfo(FrameworkName targetFramework, IsolationInformation isolationInformation, IHostSourceItem item, IHostTextEditor editor, CancellationToken cancelToken)

    and after running I have this:

    Unable to activate windows tailored application

    If I create a new XML-File, I have the following exception (designer loding):

    System.NullReferenceException
    Object reference not set to an instance of an object.
    
    Server stack trace: 
       at Microsoft.Expression.DesignHost.Isolation.Remoting.ThreadMarshaler.CallQueue.WaitForCompletion(BlockingCall call)
       at Microsoft.Expression.DesignHost.Isolation.Remoting.ThreadMarshaler.CallQueue.Invoke(BlockingCall call)
       at Microsoft.Expression.DesignHost.Isolation.Remoting.ThreadMarshaler.MarshalIn(IRemoteObject targetObject, Action action)
       at Microsoft.Expression.DesignHost.Isolation.Remoting.RemoteDesignerView.Microsoft.Expression.DesignHost.Isolation.Remoting.IRemoteDesignerView.get_Element()
       at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
       at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
    
    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at Microsoft.Expression.DesignHost.Isolation.Remoting.IRemoteDesignerView.get_Element()
       at Microsoft.Expression.DesignHost.Isolation.Remoting.LocalDesignerView.Microsoft.Expression.DesignHost.IDesignerView.get_Element()
       at Microsoft.Expression.DesignHost.IsolatedDesignerService.CreateDesignerViewInfo(FrameworkName targetFramework, IsolationInformation isolationInformation, IHostSourceItem item, IHostTextEditor editor, CancellationToken cancelToken)
    
    

    and VS is breaking down, if I reload the XAML-designer.

    I have read other threads, but they have not helped me. My screen resolution is 1317 x 1006.

     Thanks



    • Edited by Lowterm Monday, April 2, 2012 12:22 PM
    Monday, April 2, 2012 11:54 AM

Answers

  • This is for anyone having this issue as of today (4/4/12):

    I want to try to get a memory dump of the process while it is experiencing this problem:

    1) Download, install, and start the correct bitness version of DebugDiag v1.2 for your OS from this location:
    http://www.microsoft.com/download/en/details.aspx?id=26798

    2) Ensure that Visual Studio is started and ready to reproduce the problem.

    3) In DebugDiag, the Rule Wizard will appear.  At "Select Rule Type", choose "Crash" > Next

    4) Choose "A specific process" > Next

    5) Choose "devenv.exe" > Next

    6) Click "Exceptions" > "Add Exception...".  In the "Exception Code (hex)" box, put "80004005".  Change "Action Type" to "Full Userdump", and "Action Limit" to 3. > "OK" > "Save & Close" > Next

    7) You can change the rule name and location if you desire.  This will generate rather large files, so be sure you have a good bit of drive space (2-3 GB). > Next

    8)  Choose "Activate the rule now" > Finish.  If you see any additional dialog boxes, simply click "Yes" or "OK".

    9) Reproduce the problem.  You hopefully will see the "Userdump Count" column of DebugDiag increase in value, thereby indicating that we have captured the correct information.  If not, I suggest that you click the "New Rule" button, then repeat steps 3-8, with this new step replacing step 6:

    NEW STEP 6: Change "Action type for unconfigured first chance exceptions:" to "Full UserDump".  Change "Action limit for unconfigured first chance exceptions:" to 10.

    This new step will definitely create dumps.  Please zip up all dump files and place them at a location where I can download them (such as Skydrive).  Email me off-list when they are ready:  MSMALL at Microsoft.


    Matt Small - Microsoft Escalation Engineer - Forum Moderator

    • Marked as answer by Min ZhuMember Tuesday, April 24, 2012 2:54 AM
    Wednesday, April 4, 2012 1:36 PM
    Moderator
  • Hi Lowterm.

    I also got that message.

    I asked Microsoft representative about this and he told me that developers preview had expired and we need to work now on Consumers preview. I guess we just need to move on... :)

    Try to migrate your application.
    I found that this article was handy.

    Good luck!!

    Hadass

    • Proposed as answer by hadaco Tuesday, April 10, 2012 12:16 PM
    • Marked as answer by Min ZhuMember Tuesday, April 24, 2012 2:55 AM
    Tuesday, April 10, 2012 12:14 PM

All replies

  • Hi guys!

    I know it had been asked a lot around here but I feel really desperate after reading all those threads and still not able to solve my problem.

    I was working on a Metro application (that ran fine on the computer with Win8 developers preview and VisualStudio 11 ultimate (not beta)).
    I tried to install Adobe reader on the machine but failed to do so. since then (I assumed that what had caused the notification) I can't run my Metro app.

    So I searched a lot and changed resolution screen (though it ran before with that resolution), looked for code bugs (like the one on this thread ) but nothing seems to solve it so far.

    I re-installed Win8 Developers preview with dev tools, and visual studio 2011 ultimate, but even now, after re-installing, I experience the same error notification.
    It happens even if I try to run a brand new Metro application.

    The only error I see in the application is in the designer:

    System.Runtime.InteropServices.COMExceptiond
    Catastrophic failure (Exception from HRESULT: 0x8000FFFF(E_UNEXPECTED)

    Server stack trace: 
       at Microsoft.Expression.DesignHost.Isolation.Remoting.ThreadMarshaler.CallQueue.WaitForCompletion(BlockingCall call)
       at Microsoft.Expression.DesignHost.Isolation.Remoting.ThreadMarshaler.CallQueue.Invoke(BlockingCall call)
       at Microsoft.Expression.DesignHost.Isolation.Remoting.ThreadMarshaler.MarshalIn(IRemoteObject targetObject, Action action)
       at Microsoft.Expression.DesignHost.Isolation.Remoting.RemoteDesignerView.Microsoft.Expression.DesignHost.Isolation.Remoting.IRemoteDesignerView.get_Element()
       at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
       at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at Microsoft.Expression.DesignHost.Isolation.Remoting.IRemoteDesignerView.get_Element()
       at Microsoft.Expression.DesignHost.Isolation.Remoting.LocalDesignerView.Microsoft.Expression.DesignHost.IDesignerView.get_Element()
       at Microsoft.Expression.DesignHost.IsolatedDesignerService.CreateDesignerViewInfo(FrameworkName targetFramework, IsolationInformation isolationInformation, IHostSourceItem item, IHostTextEditor editor, CancellationToken cancelToken)

    Does anyone have any idea about how to solve this?
    at the moment, upgrading to Windows 8 consumer preview isn't an option.


    Monday, April 2, 2012 7:54 AM
  • Hi Lowterm - we already have a bug tracking this problem now, but no workaround.  Sorry for the inconvenience.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator

    Monday, April 2, 2012 5:11 PM
    Moderator
  • Hi Matt.

    thanks for helping. But I can not undertand. I must continue to develop my application. Is there no update for this issue?

    Thanks

    Monday, April 2, 2012 7:08 PM
  • If there was I would give it to you - it's still being investigated right now.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator

    Monday, April 2, 2012 7:49 PM
    Moderator
  • Hi Matt,

    The only work around we did to get this running was to create a new application/solution  and open the original source code using a notepad and copying them and pasting it in the new solution and it worked.

    Cheers


    Regards Biju S Melayil

    Tuesday, April 3, 2012 11:23 AM
  • Hi,

    I can't create new-projects, because I have unfortunatly the same problem with this projects too.

    Thanks

    Tuesday, April 3, 2012 11:36 AM
  • Is everybody here running into this on Developer Preview only, or is anyone seeing this on Consumer Preview?

    Matt Small - Microsoft Escalation Engineer - Forum Moderator

    Tuesday, April 3, 2012 1:32 PM
    Moderator
  • Also, please try deleting the bin folder from the project’s directory and building.


    Matt Small - Microsoft Escalation Engineer - Forum Moderator

    Tuesday, April 3, 2012 1:56 PM
    Moderator
  • I'vealreadydonethat.It has noeffect. As I said, I have also this problem with the new Apps (New project->Application) and new Items like a new User Control (XAML) in my APPs when I Add it.
    Tuesday, April 3, 2012 2:12 PM
  • Can you guys try this:  turn off the XAML Editor permanently by by right clicking on the XAML file, and choose to  open with XML editor always.  Let me know if this allows you to start the application.


    Matt Small - Microsoft Escalation Engineer - Forum Moderator

    Tuesday, April 3, 2012 5:16 PM
    Moderator
  • Hi Matt,

    I had this issue when I created the application in DP2 and started to use the same solution in DP4.
    But after DP4 we don't have this issue.

    Regards
    Biju


    Regards Biju S Melayil

    Wednesday, April 4, 2012 3:38 AM
  • Hi Matt

    Thanks for working on this. I ended up installing the consumer's preview and try now to migrate my application. I figured it had to be done at some point...

    I hope a solution will be found for Lowterm and others.

    Hadass

    Wednesday, April 4, 2012 5:53 AM
  • Hi Matt,

    thanks for helping. I have tried it with XML-Editor. I still can't start the application. I have the same issue. I can't see also the properties and methods window for XAML-Tags in a XAML file. Sometimes if I close a XAML file I get the following error:

    Microsoft Visual Studio 11 Express for Windows Developer Preview stopped working A probem caused the programm to stop working correctly. Windows will close the programm and notify you if

    a solution is available.

    Thanks

    • Edited by Lowterm Wednesday, April 4, 2012 8:24 AM
    Wednesday, April 4, 2012 7:25 AM
  • Hi Matt,

    Thanks for working on this

    I am also facing the same issue from last friday (mar-30th) on-wards.

    i tried to creat new application and it shows same error

    i installed VS-2011 Beta version, but it won't work

    i re-installed window 8 developer preview with dev tools, but still it shows the same message.

    Please let us know if any workaround for this issue.

    Thamks,

    Mani Sandeep

    Wednesday, April 4, 2012 11:14 AM
  • This is for anyone having this issue as of today (4/4/12):

    I want to try to get a memory dump of the process while it is experiencing this problem:

    1) Download, install, and start the correct bitness version of DebugDiag v1.2 for your OS from this location:
    http://www.microsoft.com/download/en/details.aspx?id=26798

    2) Ensure that Visual Studio is started and ready to reproduce the problem.

    3) In DebugDiag, the Rule Wizard will appear.  At "Select Rule Type", choose "Crash" > Next

    4) Choose "A specific process" > Next

    5) Choose "devenv.exe" > Next

    6) Click "Exceptions" > "Add Exception...".  In the "Exception Code (hex)" box, put "80004005".  Change "Action Type" to "Full Userdump", and "Action Limit" to 3. > "OK" > "Save & Close" > Next

    7) You can change the rule name and location if you desire.  This will generate rather large files, so be sure you have a good bit of drive space (2-3 GB). > Next

    8)  Choose "Activate the rule now" > Finish.  If you see any additional dialog boxes, simply click "Yes" or "OK".

    9) Reproduce the problem.  You hopefully will see the "Userdump Count" column of DebugDiag increase in value, thereby indicating that we have captured the correct information.  If not, I suggest that you click the "New Rule" button, then repeat steps 3-8, with this new step replacing step 6:

    NEW STEP 6: Change "Action type for unconfigured first chance exceptions:" to "Full UserDump".  Change "Action limit for unconfigured first chance exceptions:" to 10.

    This new step will definitely create dumps.  Please zip up all dump files and place them at a location where I can download them (such as Skydrive).  Email me off-list when they are ready:  MSMALL at Microsoft.


    Matt Small - Microsoft Escalation Engineer - Forum Moderator

    • Marked as answer by Min ZhuMember Tuesday, April 24, 2012 2:54 AM
    Wednesday, April 4, 2012 1:36 PM
    Moderator
  • Hi Matt,

    thanks but I have no exe-file named "devenv.exe" under Crash->A specific process and under "Select Target".

    Thanks


    • Edited by Lowterm Wednesday, April 4, 2012 2:31 PM
    Wednesday, April 4, 2012 2:25 PM
  • Devenv.exe is the name of the Visual Studio process.  If it's not started, then the process won't exist.  It has to be in that list or something's really wrong.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator

    Wednesday, April 4, 2012 5:35 PM
    Moderator
  • I can't find this on the other PC too. How can I start this manually and how can I repair or reinstall VS 11 (Metro-Style) under Windows 8?

    Thanks


    • Edited by Lowterm Wednesday, April 4, 2012 6:44 PM
    Wednesday, April 4, 2012 6:44 PM
  • When you have Visual Studio running, does DevEnv.exe show up in the task manager?


    Matt Small - Microsoft Escalation Engineer - Forum Moderator

    Wednesday, April 4, 2012 7:32 PM
    Moderator
  • Hi Matt,

    Thanks for your response,

    But i din't found the devenv.exe under crash->A specific process->select target.

    And also i verified in Task Manger for DenEnv.exe process but it is not there.

    Thanks.


    Thursday, April 5, 2012 6:36 AM
  • Hi Matt,

    I can't find DevEnv.exe in the task manager also.

    Thanks

    Thursday, April 5, 2012 7:12 AM
  • OK... use VSWinExpress.exe instead.  I am running the Ultimate version so my version is devenv.exe.  Sorry for the confusion.


    Matt Small - Microsoft Escalation Engineer - Forum Moderator

    Thursday, April 5, 2012 1:02 PM
    Moderator
  • Hi Matt,

    I've uploaded the dump-file and I have send you the Link for download. But I have since today a new error message.


    Error	25	Error DEP0730 : Registration of the application failed because no Developer License is installed on the target machine.
    
    Error	26	Deployment of package 37fca8b0-eead-48ae-b357-e70b97d5c264_1.0.0.0_neutral_neutral_ed0rvm6ywxf56 [Package Full Name] was blocked because no valid policy or license could be applied to it.

    How can I get a developer licence.I am very frustrated!!

    Thanks






    • Edited by Lowterm Tuesday, April 10, 2012 11:13 AM
    • Proposed as answer by hadaco Tuesday, April 10, 2012 12:06 PM
    • Unproposed as answer by hadaco Tuesday, April 10, 2012 12:06 PM
    Tuesday, April 10, 2012 11:09 AM
  • Hi Lowterm.

    I also got that message.

    I asked Microsoft representative about this and he told me that developers preview had expired and we need to work now on Consumers preview. I guess we just need to move on... :)

    Try to migrate your application.
    I found that this article was handy.

    Good luck!!

    Hadass

    • Proposed as answer by hadaco Tuesday, April 10, 2012 12:16 PM
    • Marked as answer by Min ZhuMember Tuesday, April 24, 2012 2:55 AM
    Tuesday, April 10, 2012 12:14 PM
  • I'd like to tell you that you can try to modify the system time back to several days or month ago,it may help you.I have solve my problem the same as Lowterm and the problem also attention"licence".

    I also need to use the developer preview to move on my project.

    Good luck

    jasonYu

    Tuesday, April 10, 2012 1:05 PM
  • I'd like to tell you that you can try to modify the system time back to several days or month ago,it may help you.I have solve my problem the same as you and the problem also attention"licence" using this method.

    I also need to use the developer preview to move on my project.

    Good luck

    jasonYu

    Tuesday, April 10, 2012 1:06 PM
  • Hi Hadass,

    thanks for reply. I have a relatively large project and I can not easily migrate it to Consumers. That means a lot of work. I can't find some properties and Methods under Consumers, which I had under developer.

    Thanks


    • Edited by Lowterm Tuesday, April 10, 2012 2:41 PM
    Tuesday, April 10, 2012 2:39 PM
  • Sorry Lowterm, I've been out of the office this week and just got back.

    I don't know why you would continue to develop under the DP - if there are methods that have changed from DP to CP, then there is no reason to assume that they will come back for RC or RTM. 


    Matt Small - Microsoft Escalation Engineer - Forum Moderator

    Thursday, April 12, 2012 1:52 PM
    Moderator
  • Hi Matt,

    Thanks for reply. I have migrated my APP into the CP. But I have two problems with it:

    1. Strong flickering under CP

    2. I can't find "Launcher.LaunchDefaultProgrammForFile(myFile)" no more. With alternative method "Launcher.LaunchFileAsync(myFile)" I have problems.

    Thanks


    • Edited by Lowterm Friday, April 13, 2012 12:13 PM
    Friday, April 13, 2012 11:50 AM
  • Please start a new post for issues with CP. 

    Matt Small - Microsoft Escalation Engineer - Forum Moderator

    Friday, April 13, 2012 1:17 PM
    Moderator
  • I've already done it but I got no response from you.

    http://social.msdn.microsoft.com/Forums/en-US/winformsdatacontrols/thread/ebc4e3d3-fbd9-48f9-b9b6-c0cbbdc30a4f

    Friday, April 13, 2012 1:23 PM
  • I'm sorry, I don't support winforms applications. 


    Matt Small - Microsoft Escalation Engineer - Forum Moderator

    Friday, April 13, 2012 8:37 PM
    Moderator