locked
Errors trying to use basics RRS feed

  • Question

  • User1431404321 posted

    HTTP Error 403.14 - Forbidden

    The Web server is configured to not list the contents of this directory.

    <fieldset>

    Most likely causes:

    • A default document is not configured for the requested URL, and directory browsing is not enabled on the server.
    </fieldset>
    <fieldset>

    Things you can try:

    • If you do not want to enable directory browsing, ensure that a default document is configured and that the file exists.
    •            Enable directory browsing.          
      1. Go to the IIS Express install directory.
      2. Run appcmd set config /section:system.webServer/directoryBrowse /enabled:true to enable directory browsing at the server level.
      3. Run appcmd set config ["SITE_NAME"] /section:system.webServer/directoryBrowse /enabled:true to enable directory browsing at the site level.
    • Verify that the configuration/system.webServer/directoryBrowse@enabled attribute is set to true in the site or application configuration file.
    </fieldset>
    Friday, May 16, 2014 2:21 PM

Answers

All replies

  • User-1416423428 posted

    Make sure AppPool is using .NET Framework 4.0 

    Friday, May 16, 2014 2:49 PM
  • User-1716253493 posted

    Have you set default document, i.e : Default.aspx or Home.aspx?

    try open a page like this : http://domain/default.aspx instead of http://domain/

    if work, you only need to set default document

    Friday, May 16, 2014 9:27 PM
  • User1431404321 posted

    none of those worked,,   AND,,  net 4.0 is already installed

    THis happens when I click on "run" in webmatrix with the following file.  In some cases when I click on "run" I get the IIS startup page and it shows http://localhost:8080   with no file name,   IIS cannot seem to locate the proper file even though I am in webmatrix and my file is open and saved and I click on "run"

    from the iiSEXpress - website1 msdos window

    request started "GET" http://localhost:8080/

    request ended: http://localhost:8080/iisstart.htm with HTTP status 304.0

    <!DOCTYPE html>
    <html>
    <body>
     
    <?php
    echo "My first PHP script!";
    ?>
     
    </body>
    </html>
    Saturday, May 17, 2014 12:39 PM
  • User-821857111 posted

    Questions about using WebMatrix with PHP should be asked here: http://forums.iis.net/1166.aspx/1?WebMatrix. This forum is for ASP.NET Web Pages development questions.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, May 18, 2014 4:24 AM
  • User1431404321 posted

    this really is not a php issue but a webmatrix issue.  When I run a file within webmatrix regardless of whether it is a php or html file or whatever it never runs the specific file.  Its always runs the default i.e. default.html, etc depdening on what I have set for the default.  The string passed by iis is always http://localhost:8090/  never with a filename.  I tried in the config file to add the syntax to allow the directory to be read but that did not help.  I solved the problem by changing the default to either index.php or default.asp depending on what I am doing  and naming my working script to that default.  minor cubersome but I got my files to workSmile.

    Wednesday, May 21, 2014 12:26 AM