none
ADD & REMOVE PROGRAM RRS feed

  • Question

  • I have the following in my add & remove program. Can I delete any of these lines?

     

    Microsoft .net framewwork 1.1

    Microsoft .net Framework 1.1 Hot Fix KB928366

    Microsoft .net Framwork 2.0 Service Pack

    Microsoft .net Framework 3.0 service pack

    Microsft .net Framework 3.5

     

    I am trying to clean my add & remove program &don't know what to delete.

     

    Thanks

     

    Erin

    Wednesday, April 2, 2008 1:08 PM

Answers

  • Since that a newer version supports the features of the previous ones, think that you can safely remove the earlier ones.

     

    Hope that this may be of any help (and that I'm not mistaken Stick out tongue).

     

    Wednesday, April 2, 2008 2:40 PM
  • Hi,

     

     

    You can unintstall any of these frameworks from the list

    but make sure that You does not required for the compatibility issue.

    Like VS2008 requires only 3.0 and 3.5 Framework and VS2005 requires 2.0.

     

     

    As the prerequisite of VS 2008 Express, you must keep  

    •  Microsoft .NET Framework 2.0 Service Pack 1
    •  Microsoft .NET Framework 3.0 Service Pack 1 
    •  Microsoft .NET Framework 3.5

    If you don't need to develop/run .NET 1.1 application, you can remove all .NET 1.1 stuff

    Go to Control Panel -> Choose Add/Remove Programms and select the required option from the list to uninstall.

     

     

    Thursday, April 3, 2008 4:43 AM

All replies

  • Since that a newer version supports the features of the previous ones, think that you can safely remove the earlier ones.

     

    Hope that this may be of any help (and that I'm not mistaken Stick out tongue).

     

    Wednesday, April 2, 2008 2:40 PM
  • See: http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2944204&SiteID=1

    By the way, 2.0 sp1 and 3.0 sp1 is regarded as prerequisites of .NET 3.5, so they are locked from removal if .NET 3.5 is kept.

     

    Thanks

    Thursday, April 3, 2008 3:48 AM
  • Hi,

     

     

    You can unintstall any of these frameworks from the list

    but make sure that You does not required for the compatibility issue.

    Like VS2008 requires only 3.0 and 3.5 Framework and VS2005 requires 2.0.

     

     

    As the prerequisite of VS 2008 Express, you must keep  

    •  Microsoft .NET Framework 2.0 Service Pack 1
    •  Microsoft .NET Framework 3.0 Service Pack 1 
    •  Microsoft .NET Framework 3.5

    If you don't need to develop/run .NET 1.1 application, you can remove all .NET 1.1 stuff

    Go to Control Panel -> Choose Add/Remove Programms and select the required option from the list to uninstall.

     

     

    Thursday, April 3, 2008 4:43 AM