none
oledb error mdac RRS feed

  • Question

  • i have mssql 2008 sp1 express and sql ce 3.5 sp1.

    i try to connect from compact framework on the pda to the server.

    when my application try to connect, i have this error:

    "The version of the Microsoft OLE DB Provider for SQL Server is not correct. install MDAC 2.8 or later".

    i tryed with this code:
                string strConnRemote = "Provider=SQLNCLI10;"
    
                                             + @"Data Source=SERVER4\SQLEXPRESS;"
    
                                             + "Initial Catalog=DBNET;"
    
                                             + "User id=PUBLIC;"
    
                                             + "Password=;"
    
                                             + "Integrated Security=SSPI;";
    
    
    i looked on my register and the FullInstallVer = 2.81.1132.0

    what do i wrong? 
    • Moved by Harry Zhu Thursday, March 4, 2010 3:06 AM I'm moving the thread relating to compact framework. (From:Visual C# Language)
    • Moved by Ilya TumanovMicrosoft employee Thursday, October 21, 2010 5:09 PM (From:.NET Compact Framework)
    Monday, March 1, 2010 9:42 AM

All replies

  • i have mssql 2008 sp1 express and sql ce 3.5 sp1.

    i try to connect from compact framework on the pda to the server.

    when my application try to connect, i have this error:

    "The version of the Microsoft OLE DB Provider for SQL Server is not correct. install MDAC 2.8 or later".

    i tryed with this code:
    i looked on my register and the FullInstallVer = 2.81.1132.0

    what do i wrong? 

    If you're sure it's a bug, You can submit it to the MS connect.
    Thursday, October 21, 2010 12:00 PM