none
SharePoint 2013 Register-SPWorkflowService mismatch between the Web server and database RRS feed

  • Question

  • After several hours working on the wrong Workflow Manager versions I found this download link http://www.microsoft.com/en-my/download/details.aspx?id=35375 and I got one step further, but now I not able to find any solution:

    SQL Server 2012

    SharePoint 2013 Server version: 15.0.4420.1017

    Service Bus 1.0 - Product version: 2.0.20922.0

    Workflow Manager 1.0 - Product version: 2.0.20922.0

    Workflow Manager  Client 1.0 - Product version: 2.0.20922.0

    And I have a separate AD server.

    PS C:\Users\sp_install> Register-SPWorkflowService -SPSite "http://sp13/sites/Te
    am" -WorkflowHostUri "http://sp13:12291" -AllowOAuthHttp
    Register-SPWorkflowService : There is a compatibility range mismatch between
    the Web server and database "WSS_Content", and connections to the data have
    been blocked to due to this incompatibility. This can happen when a content
    database has not been upgraded to be within the compatibility range of the Web
    server, or if the database has been upgraded to a higher level than the web
    server. The Web server and the database must be upgraded to the same version
    and build level to return to compatibility range.
    At line:1 char:1
    + Register-SPWorkflowService -SPSite "http://sp13/sites/Team" -WorkflowHostUri
    "ht ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~
        + CategoryInfo          : InvalidData: (Microsoft.Share...WorkflowService:
       RegisterSPWorkflowService) [Register-SPWorkflowService], SPUpgradeCompatib
      ilityException
        + FullyQualifiedErrorId : Microsoft.SharePoint.WorkflowServices.PowerShell
       .RegisterSPWorkflowService

    Does anyone has an idea about the error?

    Tuesday, November 13, 2012 9:31 PM

Answers