locked
Error 1069: The Service did not start due to a logon failure on 2008 R2 and 2012 after VM reboot RRS feed

  • Question

  • I believe that I have reviewed most of the common responses to this error in the forums and elsewhere.  Here is my situation.  I have 3 virtual machines, 2 running SQL 2008 R2 on Windows Server 2008 R2 and one running SQL 2012 running on Windows Server 2012.  They were all running their SQL instances fine.  Due to another issue I had to reboot one of the 2008 R2 and the 2012 machines.  Upon startup I tried to launch SSMS and received the following error:

    Cannot connect to <my instance  name> A network-related or instance-specific error occurred while establishing a connection to SQL server.  The server was not found or was not accessible.  Verify that the instance name is correct and that SQL Server is configured to allow remote connections.  Followed by:  The system cannot find the file specified.

    During my investigation I found that none of the Services had started automatically as requested.  I checked to make sure that they had the correct service account and password and they did, but I still received the Error 1069 message.  This account is working fine on the VM that I did not reboot, so I'm sure that it is not the account.  A few things that I have verified or tried include:

    • Switching the services to Local System account allows me to access SSMS and for web apps that are accessing my DB's via PHP to have access but I can't run stored procedures that require my service account
    • I have made sure that my service account has Log on as Service and Log on as Batch authorization
    • For the 2008 R2, I do not get any errors in the Application Event Viewer that are different from the other 2008 R2 account that is running fine. 
    • In the case of the 2012 instance I get the following errors and, in response, made sure that my service account had read/write access to the Sum folder.

    msmdsrv (2040) Error -1032 (0xfffffbf8) occurred while opening logfile C:\Windows\system32\LogFiles\Sum\Api.log. 

    msmdsrv (2040) An attempt to open the file "C:\Windows\system32\LogFiles\Sum\Api.log" for read only access failed with system error 5 (0x00000005): "Access is denied. ".  The open file operation will fail with error -1032 (0xfffffbf8).

    msmdsrv (2040) An attempt to open the file "C:\Windows\system32\LogFiles\Sum\Api.chk" for read / write access failed with system error 5 (0x00000005): "Access is denied. ".  The open file operation will fail with error -1032 (0xfffffbf8).


    Friday, March 9, 2018 3:35 PM

All replies

  • Hi Craig D. Brown,

    According to your description, it looks like that all your Windows account meet the permission problem on your two servers after you restarting machine.

    Please check if your SID of Windows login has been mapped to the true SID of SQL Server login. Please first refer to this blog to get the list of logins and SID recorded in SQL Server, https://www.mssqltips.com/sqlservertip/3362/map-between-sql-server-sids-and-windows-sids/

    Then use the CMD to run 'wmic useraccount get name,sid' to get the current SID map, check if they are same.

    Best Regards,

    Teige


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, March 13, 2018 8:08 AM