none
Support for Server 2019 and Office 2019 Search Roaming RRS feed

  • Question

  • Hi,

    is Outlook 2019 on Server 2019 supported for Search Roaming in Multi-User Search mode ?

    Thanks!

    Thursday, July 11, 2019 9:58 AM

All replies

  • This should work and is supported. I've reached out to the dev team to see what their experience has been with this.

    Friday, July 12, 2019 2:02 AM
    Owner
  • Installation, configuration and search hooking seems to work - according to process monitor and logs.
    But outlook does not start indexing, and shows indexing status loading forever.
    Windows update status is July 2019 and latest Office 2019 build.
    Anybody else?
    • Edited by M.Eckerle Friday, July 19, 2019 6:45 AM
    Friday, July 19, 2019 6:30 AM
  • Hello, 

    We are experiencing same behavior. Everything is working fine on WS2016, but not on WS2019. Same situation as M.Eckerle.

    Tuesday, July 23, 2019 4:59 PM
  • Randy, can you share some more troubleshooting tipps regarding the issue?
    Wednesday, July 24, 2019 9:50 AM
  • Submitted MS Support-Case yesterday. Support confirmed support for Server 2019 Multi User Search. Going through KB "Outlook Search Troubleshooting Guide" again...will keep this thread updated.
    Friday, July 26, 2019 6:35 AM
  • I too am having issues with 2019 RDSH with Office 2019 - Any update please ?
    Monday, August 19, 2019 7:12 PM
  • Hello James,

    Microsoft Now Supports Office 365 ProPlus on Windows Server 2019 (and FSLogix)

    The most common setup issues are covered in the "Outlook Search Troubleshooting Guide" for FSLogix. 

    If you are still having issues setting up FSLogix with Office 365 and Windows Server 2019, please open a ticket from: https://support.fslogix.com

    - Micah Adamson


    Monday, August 19, 2019 8:36 PM
    Owner
  • Thank you for taking the time to reply - after looking at the guide I created a ticket.

    Support request number: 119081921002460

    I tried to update the ticket online with addtional info, but when I do I get sent to azure and get the following error on the azure portal.  Do you know if I need to create another ticket with such an error ?


    Sorry, some error occurred while processing your request. Here is the tracking id edd63b86-3660-4af5-9e41-726795027ed3. Please contact Microsoft Support

    Monday, August 19, 2019 10:15 PM
  • Issue still not solved for us. Teams meeting with MS Support scheduled for today...
    Tuesday, August 20, 2019 8:46 AM
  • Thank you for the update - I appreciate you are probably very busy, but if you could find the time to update this thread with what you find, I would be most grateful!
    Tuesday, August 20, 2019 8:51 AM
  • I am having the same issue but Server 2019 with Outlook 2016. Indexing sits on loading forever. Opened a ticket and have been emailing back and forth but no resolution yet.  Ticket# 119081924004385
    Thursday, August 22, 2019 3:48 PM
  • Hello Mike,

    Thanks for letting us know you are having the same issue. I'll make sure that someone takes a look at your case today. Outlook search issues with FSLogix are most often caused by configuration problems between the many variables involved in setting it up. However, we're involving the DEV team too to make sure that there isn't a problem in the code.

    Thanks for your patience as these issues can take a while to find the cause due to the complexity of variables.

    - Micah Adamson

     

    Thursday, August 22, 2019 4:58 PM
    Owner
  • Thank you Mike.

    ...btw, no resolution for us so far.
    We went through all known troubleshooting steps again. Case still open.

    Thursday, August 22, 2019 5:10 PM
  • Hello Mike,

    is there an update to your Ticket ? Did you find any solution to solve this Issue?

    - Tobias Kothe

    Wednesday, September 11, 2019 12:34 PM
  • Our case is still open..."the dev team is still working on this issue"

    - Matthias Eckerle
    • Edited by M.Eckerle Wednesday, September 11, 2019 12:51 PM
    Wednesday, September 11, 2019 12:51 PM
  • FYI: The OneDrive DEV team and FSLogix DEV team are still investigating this issue. Sorry it's taking so long.
    Wednesday, September 11, 2019 5:23 PM
    Owner
  • Same issue here. Multi-user search does not work in Outlook 2013 on Windows 2019. Works fine in Windows 2016.

    The primary reason we're looking at Windows 2019 is files-on-demand, so that large SharePoint libraries synced to OneDrive don't eat up all FSLogix VHDs

    Friday, October 4, 2019 9:18 PM
  • Any News on this?
    Tuesday, October 15, 2019 7:07 AM
  • So here is my update and my two cents on this...
    MS support finally (after 3 month!) told us to use the "new" built-in user-based search functionality in server 2019 which seems to come with the rds role. So we have to use fslogix profile container with search roaming by fslogix disabled for now. The search database is stored in AppData\Roaming for each user.
    This is NOT reliable at all by today. Every third or fourth logon causes errors regarding search container mount and outlook indexing will break until the search service is restarted. I'm really curios why there's no documentation for user-based search functionality in rds 2019 and how on earth MS wants to support O365 on server 2019 without proper search functionality for outlook. The situation is not satisfying at all. I think we have to wait for updates.

    Any other thoughts or suggestions?

    Sunday, October 20, 2019 4:19 PM
  • The appdata per user search is enabled by default depending on the SKU. The RDSH variants of server 2019 will use the new search method. At this time, FSLogix is going to let the built in Windows search split the database instead of using the same method as we have in the past. This should provide for a more reliable search experience since FSLogix will then only have to roam the DB And the metadata. In profiles, the search database should roam correctly, but with ODFC, we are working on the feature to roam the new search database.

    Are you seeing the forever indexing issue with FSLogix profiles? And have you seen it without FSLogix on the box (Are you sure it's the per user Windows Search)?
    Monday, October 21, 2019 10:35 PM
  • @DALLINLMAG Not sure who you are addressing, but I will answer. We have gotten the perpetual indexing issue with FSLogix Search Roaming on RDSH 2019, with Outlook 2016. We ended up having to disable Search indexing of Outlook all together, with group policy, to stop Windows Search locking the OST file and crashing Outlook.
    Monday, October 21, 2019 10:41 PM
  • Any updates on this?
    Outlook search is still not working with latest windows and fslogix bits!!!

    First Login -> new container -> Outlook Cached Mode -> Index working -> Logoff

    Second Login -> existing container -> Outlook Cached Mode -> Index database not mounted ->
    Search in Outlook not working -> Logoff

    Restart RDS Host

    Next Login -> existing container -> Outlook Cached Mode -> Index working again -> LogOff

    Next Login -> existing container -> Outlook Cached Mode -> Index database not mounted -> Search in Outlook not working

    Thanks!

    2 hours 53 minutes ago
  • We have the same issue (Server & Office 2019).

    I got the 'Indexing Status' in Outlook to report back. After manually creating %AppData%\FSLogix\WSearch directory.
    The service -- don't know which one -- seemingly failed to create it.
    Immediately after creation, the typical WSearch files were created. I also ran icacls /reset /t, just as the "Search" log says.

    And still, even after rebooting and restarting and double-and-triple checking everything. The status is still the same.
    The crawler logs event 3037 (Application/Search) with an HRESULT of 0x80040d0d for mapi16://SID.

    The troubleshooting guides (both FSLogix and Outlook) don't help.

    1 hour 56 minutes ago