locked
Login Failed for User When Only TCP/IP RRS feed

  • Question

  • I am migrating a SQL Server 2000 database to SQL Server 2005 before I migrate to SQL Server 2012.  I am having the user test the application against the 2005 database to see if there are any issues first.  On the SQL Server 2000 instance he has both TCP/IP and Named Pipes enabled.  In the new environment management only wants TCP/IP enabled.  He can only log on when I enable Named Pipes.  Is there something that I can do at my end so that his application can log on with just TCP/IP or does he need to change his code to log onto the database?  I think his code is in VB.

    lcerni


    • Edited by lcerni Wednesday, May 8, 2013 12:12 PM
    Wednesday, May 8, 2013 12:08 PM

Answers

  • I created a Firewall Inbound Rule for port 1433 and now it works.

    lcerni

    • Marked as answer by lcerni Tuesday, May 14, 2013 3:14 PM
    Tuesday, May 14, 2013 3:14 PM

All replies

  • Yes, You have to enable tcp/ip. No need to change the code.

    How to enable it, http://msdn.microsoft.com/en-us/library/bb909712(v=vs.90).aspx


    Srinivasan

    Wednesday, May 8, 2013 1:02 PM
  • Yes, TCP/IP is already ENabled.  It was Named Pipes that was DISabled.

    It was failing with this configuration.  It was when I ENabled Named Pipes then the User was able to log on.  But Management would like to not enable Named Pipes.

    I am wondering do I need to do something at my end or does the user need to change his code?  I only want TCP/IP enabled.


    lcerni

    Wednesday, May 8, 2013 2:12 PM
  • In case app needs to be changed, you can add "Network Library=DBMSSOCN" clause in connection string.

    http://geekswithblogs.net/brcraju/archive/2004/02/03/1689.aspx


    Srinivasan

    Wednesday, May 8, 2013 2:48 PM
  • He has altered his code but is now getting this.  There is nothing in the logs.


    lcerni

    Wednesday, May 8, 2013 6:25 PM
  • I believe now that this error is do to network issues.  Waiting on the developer.

    lcerni

    Friday, May 10, 2013 1:32 PM
  • I created a Firewall Inbound Rule for port 1433 and now it works.

    lcerni

    • Marked as answer by lcerni Tuesday, May 14, 2013 3:14 PM
    Tuesday, May 14, 2013 3:14 PM