locked
problem to deploy RRS feed

  • Question

  • User-286327145 posted

    I upload my website to our web server. but there is a problem when i try to display the first page:


    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Compilation Error
    Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

    Compiler Error Message: CS0246: The type or namespace name 'ServerConnection' could not be found (are you missing a using directive or an assembly reference?)

    Source Error:

    public partial class ClientDetails : System.Web.UI.Page
    {
        private bool isFirst = false;    
        private ServerConnection conn = null; //***Error in this line
    }

    Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

    Note: the "ServerConnection" is a classname. i tried to use the methods of this class. so i created an instance of this class.

    the application is compiled successfully and runned successfully on my local machine.

    Do you know how to solve this issue?

    thanks.

    Thursday, March 1, 2007 11:58 PM

All replies

  • User1091955703 posted
    Is that class in a separate namespace or assembly?

    Does this work locally I take it?

    Are you making an references to this assembly/namespace via web.config?
    Friday, March 2, 2007 12:46 AM
  • User-286327145 posted

    That class is in the same assembly.

    It works fine in my local machine.

    I didn't make reference to this assembly via web.config because the class file is in the same folder/domain as the code behind file.

    (We also coppied the Bin folder to the web server.) 

     

    Sunday, March 4, 2007 9:53 PM
  • User-286327145 posted

    Now please give me some idea....... what to do next???

    Monday, March 5, 2007 7:18 PM
  • User-286327145 posted
    I solved.................thanks.
    Monday, March 5, 2007 10:30 PM