none
Outlook Add-In not loading due to error loading COM Add-In RRS feed

  • Question

  • Hi,

    I've written an Office Outlook 2007 add-in in C# using VSTO 2005 Team Edition. The add-in works fine when using VSTO to launch the Add-In, but when I install the Add-In using the Setup solution, outlook fails to load the Add-In with the error: Not Loaded. A runtime error occured during the loading of the COM add-in.

    Using Fusion, I have found the following:

    *** Assembly Binder Log Entry  (04/02/2012 @ 01:43:55) ***
    
    The operation failed.
    Bind result: hr = 0x80070002. The system cannot find the file specified.
    
    Assembly manager loaded from:  C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\mscorwks.dll
    Running under executable  C:\PROGRA~1\MICROS~2\Office12\OUTLOOK.EXE
    --- A detailed error log follows. 
    
    === Pre-bind state information ===
    LOG: User = EMEA\BallantyneR
    LOG: DisplayName = Operations Request Renamer, Version=1.0.0.0, Culture=neutral
     (Partial)
    LOG: Appbase = file:///C:/Program Files/Computershare/Operations Request Renamer/
    LOG: Initial PrivatePath = NULL
    LOG: Dynamic Base = NULL
    LOG: Cache Base = NULL
    LOG: AppName = NULL
    Calling assembly : (Unknown).
    ===
    LOG: Start binding of native image Operations Request Renamer, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null.
    LOG: IL assembly loaded from C:\Documents and Settings\ballantyner\Local Settings\Application Data\assembly\dl3\WW5HCVLB.RKW\LM1CKHHL.27R\8344cfed\00f917ac_d7e2cc01\Operations Request Renamer.dll.
    WRN: No matching native image found.
    LOG: Bind to native image assembly did not succeed. Use IL image.
    
    
    

    I've tried installing various patches and interops, and have looked in to Ngen.exe, but I just don't have the expertise... Any help figuring out my next step would be appreciated.

    It's running on XP SP3.

    Regards
    Ross

    • Moved by Jie BaoModerator Monday, February 6, 2012 2:11 AM (From:Application Compatibility for Windows Desktop Development)
    Saturday, February 4, 2012 1:50 AM

Answers

All replies

  • try to remove ngen image of your addin and do not add new one (comment out code that creates ngen image from your installer). Does it work then?
    Monday, February 6, 2012 10:06 AM
  • Hi Ross,

    Have you tried copied the ClickOnce install package to some other machine which has Outlook 2007 installed to see what happened?

    If the setup can work on other machines but not on your development machine, the issue might caused by that the setup conflict with VSTO debug add-in. Have a try unload the add-in first:

    Open the VSTO solution -> Build -> Clear Solution

    I hope this helps.


    Calvin Gao[MSFT]
    MSDN Community Support | Feedback to us

    Monday, February 13, 2012 10:49 AM
    Moderator
  • Hi,

    Thanks for your replies, unfortunately I still can't get it working. The problem is, the add-in works perfectly when launched on the development machine from VSTO. It doesn't work when I publish it, either on the development machine or the target machine (which is identical in terms of OS / Office install, etc).

    I'm neither familiar with ClickOnce installation, ngen or modifying my own installer...

    Any info / links that may be of some help would be appreciated :)

    Tuesday, February 14, 2012 6:47 PM
  • Hi,

    This might be an defect of VSTO 2005 SE version, and because the support for VS 2005 product family expires at April 2011, you might need to contact professional paid support to resolve issue:

    http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    Alernatively you can chagne to use VS 2008 or VS 2010, furthermore, both VS 2008 and 2010 support to upgrade VSTO solution created in earlier version of VS, see:

    http://msdn.microsoft.com/en-us/library/4bez6837.aspx

    and:

    http://msdn.microsoft.com/en-us/library/k2xkefex.aspx

    I hope this helps.


    Calvin Gao[MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, February 15, 2012 2:56 AM
    Moderator
  • Thanks Calvin,

    I have a friend with VSTO 2010 who has offered to build my solution... I'll let you know if this fixes the problem!

    Thursday, February 16, 2012 1:37 AM