none
An unknown COM+ 1.0 catalog error occurred:Exception from HRESULT: 0x80110401 RRS feed

  • Question

  • Hello,

    I am trying to register a COM+ component using regsvcs in windows2012 server, however getting below error, after lot of search I am unable to solve this issue. Request your help to fix this,

    BInaries are strongnamed, Any Cpu build, Release mode, .NET 3.5

    Microsoft (R) .NET Framework Services Installation Utility Version 2.0.50727.800
    7
    Copyright (c) Microsoft Corporation.  All rights reserved.
    
    WARNING: The assembly does not declare an ApplicationAccessControl Attribute.  A
    pplication security will be enabled by default.
    
    An unknown COM+ 1.0 catalog error occurred:
    1: Errors occurred accessing one or more objects - the ErrorInfo collection may
    have more detail (Exception from HRESULT: 0x80110401)
    Appreciate your help.

    Friday, March 23, 2018 7:55 AM

All replies

  • Without posting any code we aren't going to be able to help you. The problem could be anywhere. Verify your COM object is actually exposed properly. Ensure that it is defining a proper COM interface. Ensure all the types used in the interface are valid. The list goes on and on.

    Michael Taylor http://www.michaeltaylorp3.net

    Friday, March 23, 2018 1:57 PM
    Moderator
  • The warning can be fixed by setting the appropriate security attributes:

    http://www.windowsdevcenter.com/pub/a/dotnet/excerpt/com_dotnet_ch10/index.html?page=9

    I don't know what is causing the error but I would check the Windows Event Log for more info.


    Paul ~~~~ Microsoft MVP (Visual Basic)

    • Proposed as answer by Stanly Fan Tuesday, March 27, 2018 9:44 AM
    Friday, March 23, 2018 2:30 PM