none
Help needed: DEP0001 Unexpected Error -2147467259

    Question

  • Hi, whenever I try to run and/or deploy an app on Visual Studio 2015 I get this error DEP0001 Unexpected Error -2147467259 and can't test anything wether it's on mobile or emulator (different error on mobile).

    I reinstalled VS15 today and the app is the generated Pivot app by VS so there shouldn't be any problem right?

    IpOverUsbSvc is running, developer mode is enabled, I even installed W10 today.

    If anybody has any idea, that'd be much appreciated.

    Thanks!

    Thursday, December 15, 2016 8:53 PM

Answers

  • Hi SomanZ,

    Please make sure that you have installed all components about UWP and Windows Phone Tools. Please refer to the following screenshot:

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by SomanZ Monday, December 26, 2016 12:25 PM
    Monday, December 19, 2016 7:52 AM
    Moderator

All replies

  • Hi SomanZ,

    Thanks for your post.

    If you met this issue just after you installed VS, please repair it and refer to the steps below:

    Start-> control panel -> programs and features -> choose change -> in the setup wizard choose repair

    Or if this issue just shows recently and it worked fine before, then it’s probably caused by third-party plug-ins. To run Visual Studio in the safe mode could help us to check it.

    Run VS in safe mode steps:

    Open command Prompt -> type  devenv /SafeMode  in command line and -> hit Enter button

    Please also check the following things:

    1). Update Visual Studio 2015 to the latest version, Update 3.

    2). Uninstall the app from phone, rebuild solution and then try debug again

    3). Check that the architecture for all projects is set accordingly (ARM for debugging on real device)

    4). Sometimes the VS debugger hangs up, so closing VS and kill from Task Manager all VS processes that are eventually running and restart VS may help.

    5). Delete all files under the following folders:

    C:\Users\<your users name>\AppData\Local\Microsoft\VisualStudio\14.0 and

    C:\Users\<your users name>\AppData\Roaming\Microsoft\VisualStudio\14.0

    Best regards,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, December 16, 2016 5:47 AM
    Moderator
  • Hi, thanks for your help.

    I repaired VS and it didn't change anything.

    I tried launching VS in safe mode, and then load my project but got this error message:

    "Unsupported
    This version of Visual Studio is unable to open the following projects. The project types may not be installed or this version of Visual Studio may not support them.
    For more information on enabling these project types or otherwise migrating your assets, please see the details in the "Migration Report" displayed after clicking OK.
         - netsil, "E:\git\wpapp_netsil\netsil\netsil.csproj"


    Non-functional changes required
    Visual Studio will automatically make non-functional changes to the following projects in order to enable them to open in Visual Studio 2015, Visual Studio 2013, Visual Studio 2012, and Visual Studio 2010 SP1. Project behavior will not be impacted.
         - netsil, "E:\git\wpapp_netsil\netsil.sln" "

    Also my version was already on the version 3 of VS.

    I never put the app on my phone, I'm just trying to load it on the VS emulator.

    I also have tried to change the architecture and tried different things, but none did resolve the problem.

    Closing all processes in the task manager did nothing either.

    Deleting the files in the foder didn't change anything.

    Thank you again for your help thouhg, it's very appreciated. I just can"t seem to make anything work...

    Friday, December 16, 2016 9:25 AM
  • Hi SomanZ,

    Please create a new project to make sure that VS 2015 could test the new app well, which could help us to exclude the reasons caused by VS.

    According to the error messages, it’s probably caused by the compatibility between your project and VS2015.

    I suggest that you could copy the content of old project to the new one and try it again.

    Please let me know your latest results.

    Best regards,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, December 16, 2016 9:47 AM
    Moderator
  • Hey again

    tried creating a new fresh app directly from the templates inside VS15 and I still have the same problem. I jsut create the app, hit the Emulator 8.1 button, the emulator pops in followed by the error in the Error List windows of the editor.

    Friday, December 16, 2016 4:22 PM
  • Hi SomanZ,

    Please make sure that you have installed all components about UWP and Windows Phone Tools. Please refer to the following screenshot:

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by SomanZ Monday, December 26, 2016 12:25 PM
    Monday, December 19, 2016 7:52 AM
    Moderator
  • THAT WORKED!

    Thank you so much! Happy holidays to you =)

    Monday, December 26, 2016 12:25 PM