none
Visual Studio 2017 installation: "Sorry, the product definitions failed to load"

    Question

  • I'm not able to launch Visual Studio 2017 Installer. The log contains following error:

    Both channel manifest uri and install channel manifest uri are not set.

    Where can I set missing URLs?

    Full log:

    2017-04-20T09:00:18 : Verbose : Visual Studio Installer (1.9.30405.1 : release) ["C:\\Program Files (x86)\\Microsoft Visual Studio\\Installer\\vs_installershell.exe"]
    2017-04-20T09:00:19 : Verbose : Received the application ready notification
    2017-04-20T09:00:19 : Verbose : Telemetry Session ID: 4a6d5881-7b5d-443e-883d-9036e0ee2c8d
    2017-04-20T09:00:19 : Verbose : Getting installed product summaries. [installerId: SetupEngine]
    2017-04-20T09:00:19 : Verbose : Starting the installed products provider service.
    2017-04-20T09:00:19 : Verbose : Starting the products provider service.
    2017-04-20T09:00:19 : Verbose : Getting product summaries. [installerId: SetupEngine]
    2017-04-20T09:00:19 : Verbose : Starting the installer service.
    2017-04-20T09:00:21 : Verbose : Connected to Hub Controller's client watch 'net.pipe://16da849516631a1acbcf7853f9131117'
    2017-04-20T09:00:21 : Verbose : Calling SetupEngine.Installer.Initialize. [locale: cs-CZ]
    2017-04-20T09:00:21 : Verbose : SetupEngine.Installer.Initialize succeeded. [locale: cs-CZ]
    2017-04-20T09:00:21 : Verbose : Started the installer service.
    2017-04-20T09:00:21 : Verbose : Calling SetupEngine.Installer.IsElevated.
    2017-04-20T09:00:21 : Verbose : SetupEngine.Installer.IsElevated succeeded.
    2017-04-20T09:00:22 : Error : Failed to start the products provider service. error: Both channel manifest uri and install channel manifest uri are not set. at    v Microsoft.VisualStudio.Setup.Cache.ChannelManifestRepository.ValidateChannelUris(IChannelManifest channelManifest, IChannelManifest installChannelManifest)
       v Microsoft.VisualStudio.Setup.Cache.ChannelManifestRepository.GetChannels(String searchRoot)
       v Microsoft.VisualStudio.Setup.Cache.ChannelManifestRepository.GetChannels()
       v Microsoft.VisualStudio.Setup.Cache.CacheManager.GetChannels()
       v Microsoft.VisualStudio.Setup.ChannelManager.CleanupInstallChannels()
       v Microsoft.VisualStudio.Setup.ProductsProviderService.<Initialize>d__5.MoveNext()
    2017-04-20T09:00:22 : Error : Failed to start the installed products provider service. error: Both channel manifest uri and install channel manifest uri are not set. at    v Microsoft.VisualStudio.Setup.Cache.ChannelManifestRepository.ValidateChannelUris(IChannelManifest channelManifest, IChannelManifest installChannelManifest)
       v Microsoft.VisualStudio.Setup.Cache.ChannelManifestRepository.GetChannels(String searchRoot)
       v Microsoft.VisualStudio.Setup.Cache.ChannelManifestRepository.GetChannels()
       v Microsoft.VisualStudio.Setup.Cache.CacheManager.GetChannels()
       v Microsoft.VisualStudio.Setup.ChannelManager.CleanupInstallChannels()
       v Microsoft.VisualStudio.Setup.ProductsProviderService.<Initialize>d__5.MoveNext()
    2017-04-20T09:00:22 : Error : Failed to get product summaries. [installerId: SetupEngine, error: ArgumentException at Both channel manifest uri and install channel manifest uri are not set.
       v Microsoft.VisualStudio.Setup.Cache.ChannelManifestRepository.ValidateChannelUris(IChannelManifest channelManifest, IChannelManifest installChannelManifest)
       v Microsoft.VisualStudio.Setup.Cache.ChannelManifestRepository.GetChannels(String searchRoot)
       v Microsoft.VisualStudio.Setup.Cache.ChannelManifestRepository.GetChannels()
       v Microsoft.VisualStudio.Setup.Cache.CacheManager.GetChannels()
       v Microsoft.VisualStudio.Setup.ChannelManager.CleanupInstallChannels()
       v Microsoft.VisualStudio.Setup.ProductsProviderService.<Initialize>d__5.MoveNext()]
    2017-04-20T09:00:22 : Error : Failed to get installed product summaries. [installerId: SetupEngine, error: ArgumentException at Both channel manifest uri and install channel manifest uri are not set.
       v Microsoft.VisualStudio.Setup.Cache.ChannelManifestRepository.ValidateChannelUris(IChannelManifest channelManifest, IChannelManifest installChannelManifest)
       v Microsoft.VisualStudio.Setup.Cache.ChannelManifestRepository.GetChannels(String searchRoot)
       v Microsoft.VisualStudio.Setup.Cache.ChannelManifestRepository.GetChannels()
       v Microsoft.VisualStudio.Setup.Cache.CacheManager.GetChannels()
       v Microsoft.VisualStudio.Setup.ChannelManager.CleanupInstallChannels()
       v Microsoft.VisualStudio.Setup.ProductsProviderService.<Initialize>d__5.MoveNext()]

    Thursday, April 20, 2017 7:04 AM

Answers

  • I have fixed the issue by deleting following folder: C:\Users\<profile>\AppData\Microsoft\VisualStudio\Packages\_Channels

    Thursday, April 20, 2017 7:22 AM

All replies

  • I have fixed the issue by deleting following folder: C:\Users\<profile>\AppData\Microsoft\VisualStudio\Packages\_Channels

    Thursday, April 20, 2017 7:22 AM
  • Hi Václav Dajbych,

    Welcome to MSDN forum.

    Glad to know that you have solved it by yourself and thank you for sharing your solutions here, which will be helpful for those who has the similar issue with you.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, April 21, 2017 1:54 AM